Modify

Opened 3 years ago

Closed 5 weeks ago

#14465 closed enhancement (fixed)

"Open in browser" should support multiple objects

Reported by: nyurik Owned by: simon04
Priority: normal Milestone: 20.01
Component: Core tag2link Version:
Keywords: Cc:

Description (last modified by Don-vip)

Just like history viewer, open in browser should allow to open multiple browser tabs, and warn if too many objects are selected.

Edit
Selecting "View Wikipedia article" opens Wikipedia main page instead of all selected articles:

Attachments (5)

14465_worksforme.PNG (10.5 KB) - added by Don-vip 3 years ago.
14465_multiple_selection.png (19.6 KB) - added by Don-vip 2 years ago.
2020-01-11-wikipedia.png (14.4 KB) - added by simon04 5 weeks ago.
toomuchduck.png (147.2 KB) - added by Don-vip 5 weeks ago.
2020-01-13-tag2link.png (9.8 KB) - added by simon04 5 weeks ago.

Download all attachments as: .zip

Change History (31)

Changed 3 years ago by Don-vip

Attachment: 14465_worksforme.PNG added

comment:1 Changed 3 years ago by Don-vip

This is already implemented:


Or I didn't understand what you're asking.

Last edited 3 years ago by Don-vip (previous) (diff)

comment:2 Changed 3 years ago by Don-vip

Owner: changed from team to nyurik
Status: newneedinfo

comment:3 Changed 3 years ago by nyurik

When I right-click on an objet in the selection panel, I can open corresponding Wikipedia entry (I think wikipedia plugin does this, but it may be website linker plugin), it only shows one Wikipedia page. If I have multiple objects selected, only the current one is shown. If I select all lines in the selected panel, it still shows just the current one. Lastly, if I right click on the "wikipedia" tag in the object tag editor panel, and it shows multiple values, it opens Wikipedia's main page instead of all of them.

comment:4 Changed 3 years ago by Don-vip

Component: CorePlugin tag2link

comment:5 Changed 3 years ago by Don-vip

Owner: changed from nyurik to Don-vip
Status: needinfonew

Changed 2 years ago by Don-vip

comment:6 Changed 2 years ago by Don-vip

Description: modified (diff)

comment:7 Changed 5 months ago by Don-vip

In 15376/josm:

see #14465 - allow plugins to retrieve selected tags with multiple values

comment:8 Changed 5 months ago by Don-vip

First part coded in [o35134].

comment:9 Changed 4 months ago by Don-vip

regression: #18253

Changed 5 weeks ago by simon04

Attachment: 2020-01-11-wikipedia.png added

comment:10 Changed 5 weeks ago by simon04

Since r15673, all Wikipedia articles are shown in the popup: Their target is shown as tooltip. Is this sufficient?


comment:11 Changed 5 weeks ago by nyurik

I would say this is actually worse than before. Having a huge list of identical items, without any ability to scroll the context menu beyond the screen height (so impossible to access lower items), and without any clue of which corresponds to what until I mouse over it (so I have to go one-by-one through them), makes the feature far less useful.

On top of that, most of the time I want to open all unique wikipedia/wikidata tabs for a set of object. With this feature, I can only access one at time.

Changed 5 weeks ago by Don-vip

Attachment: toomuchduck.png added

comment:12 Changed 5 weeks ago by Don-vip

Indeed the UI is a huge problem right now. On relations with many tags the links take all the screen space:


Last edited 5 weeks ago by Don-vip (previous) (diff)

comment:13 Changed 5 weeks ago by Don-vip

Owner: changed from Don-vip to simon04

comment:14 Changed 5 weeks ago by simon04

In 15706/josm:

see #14465 -Tag2Link: combine links with same name and launch at once

comment:15 Changed 5 weeks ago by simon04

In 15707/josm:

see #14465 -Tag2Link: consider all selected primitives/properties

Changed 5 weeks ago by simon04

Attachment: 2020-01-13-tag2link.png added

comment:16 Changed 5 weeks ago by simon04

Now, multiple links with the same name are combined and can be launched at once. Also, all selected properties (from PropertiesDialog), relations (from MembershipDialog and RelationListDialog), primitives (from SelectionListDialog) are taken into account.


comment:17 Changed 5 weeks ago by Don-vip

Nice!

comment:18 Changed 5 weeks ago by Don-vip

We could also add specific icons for Wikipedia, Wikidata and Wikimedia Commons. I guess they're free.

comment:19 Changed 5 weeks ago by Don-vip

Milestone: 20.01

comment:20 in reply to:  16 Changed 5 weeks ago by Don-vip

Replying to simon04:

Now, multiple links with the same name are combined and can be launched at once.

I'm not sure this the way to go for name:* tags when I right click an object. I'm only interested in the name tag matching (my) JOSM language, and not all the (sometimes 30+) others.

comment:21 Changed 5 weeks ago by nyurik

Exciting, thanks for working on it! One note though -- I noticed that when i searched for many objects with wikidata tag, and right clicked on the wikidata tag's values, I see menu items like "Open in Wikidata Qnnnn", where that nnnn is different on each line. Will your fix handle that? Thx!

comment:23 in reply to:  21 Changed 5 weeks ago by Klumbumbus

Replying to nyurik:

I see menu items like "Open in Wikidata Qnnnn", where that nnnn is different on each line. Will your fix handle that? Thx!

Thats already fixed in r15706. Please try josm latest version tomorrow.

comment:24 Changed 5 weeks ago by nyurik

Tried it, looks very good, thanks!

comment:25 Changed 5 weeks ago by Klumbumbus

In 15709/josm:

see #14465 - adapt unit test to r15706

comment:26 Changed 5 weeks ago by simon04

In 15711/josm:

see #14465 - Tag2Link: restrict names by JOSM language

comment:27 Changed 5 weeks ago by simon04

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.