Modify

Opened 2 years ago

Closed 21 months ago

#14432 closed defect (fixed)

NPE at StopImporterDialog.setWaypointsTableModel

Reported by: eoDA Owned by: roland.olbricht
Priority: normal Milestone:
Component: Plugin public_transport Version: tested
Keywords: template_report Cc:

Description (last modified by Don-vip)

Anwendung des Plug-ins "public transport (Version 33166)": Einfügen eines Wegpunkts mit einer gpx-Datei

What steps will reproduce the problem?

  1. Auswahl der Option "Haltestellen aus GPX erstellen"
  2. Auswahl einer Datei *.gpx, die nur 1 Wegpunkt enthält
  3. Öffnen der Datei

What is the expected result?

(Mindestens)plazieren des Punktes auf der Karte ... ?

What happens instead?

Fehlermeldung

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-26 23:10:22 +0100 (Sun, 26 Feb 2017)
Build-Date:2017-02-26 22:34:39
Revision:11639
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11639 de) Windows 10 64-Bit
Memory Usage: 534 MB / 910 MB (142 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1280x1024
Maximum Screen Size: 1280x1024
Dataset consistency test: No problems found

Plugins:
+ public_transport (33166)

Last errors/warnings:
- W: Erweiterungen aktualisieren - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: Invalid jar file ''<josm.pref>\plugins\public_transport.jar.new'' (exists: false, canRead: false)
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (20) of main
java.lang.NullPointerException
	at public_transport.StopImporterDialog.setWaypointsTableModel(StopImporterDialog.java:524)
	at public_transport.StopImporterAction.refreshData(StopImporterAction.java:212)
	at public_transport.StopImporterAction.actionPerformed(StopImporterAction.java:105)
	at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
	at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
	at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
	at javax.swing.AbstractButton.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseReleased(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by stoecker

Component: CorePlugin public_transport
Owner: changed from team to roland.olbricht

comment:2 Changed 2 years ago by Klumbumbus

Description: modified (diff)

comment:3 Changed 2 years ago by Don-vip

Description: modified (diff)
Summary: Anwendung des Plug-ins "public transport (Version 33166)": Einfügen eines Wegpunkts mit einer gpx-DateiNPE at StopImporterDialog.setWaypointsTableModel

comment:4 Changed 2 years ago by Don-vip

Ticket #14691 has been marked as a duplicate of this ticket.

comment:5 Changed 23 months ago by Don-vip

Ticket #15202 has been marked as a duplicate of this ticket.

comment:6 Changed 21 months ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o33770:33771].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain roland.olbricht.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.