Modify

Opened 2 years ago

Closed 2 years ago

#14376 closed enhancement (fixed)

Update of values for amenity=vending_machine preset

Reported by: chrabros Owned by: team
Priority: normal Milestone: 17.02
Component: Internal preset Version:
Keywords: amenity vending machine Cc:

Description (last modified by chrabros)

Hi,
could someone please update the values for vending= in amenity=vending_machine preset?

I would suggest to add these values which are often used and I have created a wiki documentation for some of them:

bottle_return
chewing_gums
coffee
ice_cubes
ice_cream
water

Also I would like to remove the value vending=photos as it is not recommended on wiki
and add a note in validator/deprecated.mapcss that you should use amenity=photo_booth instead.

BTW I would like to document the value public_transport_plans but I have no idea what is means. If you do, please update the page here: https://wiki.openstreetmap.org/wiki/Tag:vending%3Dpublic_transport_plans

Thanks,

Dalibor

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by chrabros

Description: modified (diff)

comment:2 Changed 2 years ago by Don-vip

Keywords: amenity machine added

comment:3 Changed 2 years ago by Klumbumbus

Milestone: 17.02

See our guidelines for new tags.

  • vending value - current usage number - decision
  • bottle_return - 12 - too low
  • chewing_gums - 164 - too low and a duplicate of sweets in my eyes
  • coffee - 250 - low usage, but I think ok to add
  • ice_cubes - 12 - too low
  • ice_cream - 39 - too low
  • water - 126 - too low
  • photos - 209 - will be removed and the validator warning added
  • public_transport_plans - 75 - I assume maps of the public transport routes of a city or region. see google image search for "public transport plan", however very low usage number even after years in the josm preset - will be removed.
Last edited 2 years ago by Klumbumbus (previous) (diff)

comment:4 Changed 2 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 11583/josm:

fix #14376 - update vending values: remove public_transport_plans, add coffee, deprecate photos and photo in favor of amenity=vending_booth, add it to presets and mappaint style, new icon self created, CC0 and PD licensed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.