Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#14356 closed defect (fixed)

NPE at PasteMembersAction.getSupport

Reported by: Mirecnet Owned by: team
Priority: normal Milestone: 17.02
Component: Core Version:
Keywords: template_report javabug Cc:

Description (last modified by Don-vip)

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-02-11 20:25:23 +0100 (Sat, 11 Feb 2017)
Build-Date:2017-02-12 02:34:26
Revision:11551
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11551 sk) Linux Ubuntu 16.04.2 LTS
Memory Usage: 831 MB / 1753 MB (678 MB allocated, but free)
Java version: 1.8.0_121-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Last errors/warnings:
- E: java.lang.NullPointerException: Failed to retrieve atom name.
- E: java.lang.NullPointerException: Failed to retrieve atom name.
- E: Handled by bug report queue: java.lang.NullPointerException: Failed to retrieve atom name.
- E: Handled by bug report queue: java.lang.NullPointerException: Failed to retrieve atom name.
- E: Handled by bug report queue: java.lang.NullPointerException: Failed to retrieve atom name.
- E: Handled by bug report queue: java.lang.NullPointerException: Failed to retrieve atom name.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NullPointerException: Failed to retrieve atom name.
	at sun.awt.X11.XlibWrapper.XGetAtomName(Native Method)
	at sun.awt.X11.XAtom.getName(XAtom.java:186)
	at sun.awt.X11.XDataTransferer.getTargetNameForAtom(XDataTransferer.java:165)
	at sun.awt.X11.XDataTransferer.getNativeForFormat(XDataTransferer.java:154)
	at sun.awt.datatransfer.DataTransferer.getFlavorsForFormats(DataTransferer.java:736)
	at sun.awt.datatransfer.ClipboardTransferable.<init>(ClipboardTransferable.java:90)
	at sun.awt.X11.XClipboard.getContents(XClipboard.java:108)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.PasteMembersAction.getSupport(PasteMembersAction.java:44)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.PasteMembersAction.updateEnabledState(PasteMembersAction.java:50)
	at org.openstreetmap.josm.gui.dialogs.relation.actions.PasteMembersAction.<init>(PasteMembersAction.java:31)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor$3.<init>(GenericRelationEditor.java:277)
	at org.openstreetmap.josm.gui.dialogs.relation.GenericRelationEditor.<init>(GenericRelationEditor.java:277)
	at org.openstreetmap.josm.gui.dialogs.relation.RelationEditor.getEditor(RelationEditor.java:115)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPreset.lambda$actionPerformed$2(TaggingPreset.java:411)
	at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by Don-vip

Keywords: javabug added
Milestone: 17.02

comment:2 Changed 2 years ago by Don-vip

Description: modified (diff)
Summary: relaciaNPE at PasteMembersAction.getSupport

comment:3 Changed 2 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 11554/josm:

fix #14356 - make sure that workaround for JDK-6322854 is used everywhere

comment:4 Changed 2 years ago by Don-vip

Ticket #14362 has been marked as a duplicate of this ticket.

comment:5 Changed 2 years ago by Don-vip

Ticket #14388 has been marked as a duplicate of this ticket.

comment:6 Changed 2 years ago by Don-vip

Ticket #14406 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.