Modify

Opened 5 years ago

Closed 5 years ago

#14307 closed defect (fixed)

Can't import images from local computer to Mapillary

Reported by: vazhnov@… Owned by: nokutu
Priority: normal Milestone:
Component: Plugin mapillary Version: tested
Keywords: template_report apache-commons Cc:

Description

What steps will reproduce the problem?

  1. Install plugin Mapillary;
  2. File → Download from OSM → Download;
  3. File → Import pictures (or Import pictures into sequence);
  4. Select any picture with GPS tags (or multiple) → Open.

What is the expected result?

Importing images.

What happens instead?

Window with error (unexpected exception), no images were imported.

Please provide any additional information below. Attach a screenshot if possible.

I tried to select images created by Mapillary app for Android as well as images created by Open Camera (http://opencamera.sourceforge.net/)

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-01-02 00:53:29 +0100 (Mon, 02 Jan 2017)
Build-Date:2017-01-02 02:33:21
Revision:11427
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11427 ru) Linux Ubuntu 16.04.1 LTS
Memory Usage: 340 MB / 1102 MB (108 MB allocated, but free)
Java version: 1.8.0_121-8u121-b13-0ubuntu1.16.04.2-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u121-b13-0ubuntu1.16.04.2
Dataset consistency test: No problems found

Plugins:
+ Mapillary (v1.3.2)
+ apache-commons (32994)
+ apache-http (32699)
+ imagery_offset_db (33004)
+ photo_geotagging (33088)
+ photoadjust (33088)
+ reverter (33088)

Last errors/warnings:
- E: Handled by bug report queue: java.lang.NoSuchFieldError: GPS_TAG_GPS_LATITUDE


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.NoSuchFieldError: GPS_TAG_GPS_LATITUDE
	at org.openstreetmap.josm.plugins.mapillary.utils.ImageUtil.readImageFrom(ImageUtil.java:90)
	at org.openstreetmap.josm.plugins.mapillary.utils.ImageUtil.readImagesFrom(ImageUtil.java:61)
	at org.openstreetmap.josm.plugins.mapillary.actions.MapillaryImportAction.chooseImages(MapillaryImportAction.java:94)
	at org.openstreetmap.josm.plugins.mapillary.actions.MapillaryImportAction.actionPerformed(MapillaryImportAction.java:123)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6533)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6298)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:90)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (1)

IMG_20160826_190203.jpg (3.0 MB) - added by vazhnov@… 5 years ago.
Image example with GPS tags (Russia, Chelyabinsk); license CC-BY-SA 4.0

Change History (2)

Changed 5 years ago by vazhnov@…

Attachment: IMG_20160826_190203.jpg added

Image example with GPS tags (Russia, Chelyabinsk); license CC-BY-SA 4.0

comment:1 Changed 5 years ago by floscher

Keywords: apache-commons added
Resolution: fixed
Status: newclosed

Thank you for reporting, this was not an issue with the Mapillary plugin itself. The plugin apache-commons was changed incompatibly since the last release, which caused the Mapillary plugin to fail.
I simply recompiled the version v1.3.2 of the plugin against the latest version of the apache-commons plugin.
So if you update your JOSM plugins (go to the JOSM preferences, in the Plugins section there is a button to update the plugins at the bottom) and restart JOSM, you should be able to import images again.

(This issue is the same as reported in https://github.com/JOSM/Mapillary/issues/36)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nokutu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.