Modify

Opened 3 years ago

Closed 3 years ago

#14250 closed defect (duplicate)

System error message at startup

Reported by: AlaskaDave Owned by: Nipel-Crumple
Priority: normal Milestone:
Component: Plugin rasterfilters Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

This release has caused problems on my system continuously. I've experienced many system hangs that required Task Manager to end Java instance and now this. I'm going back to the previous version.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2017-01-02 00:53:29 +0100 (Mon, 02 Jan 2017)
Build-Date:2017-01-02 02:33:21
Revision:11427
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11427 en) Windows 10 64-Bit
Memory Usage: 254 MB / 989 MB (147 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ DirectDownload (33004)
+ DirectUpload (32885)
+ FastDraw (33004)
+ InfoMode (33004)
+ OpeningHoursEditor (33004)
+ SeaMapEditor (33054)
+ apache-commons (32994)
+ apache-http (32699)
+ buildings_tools (33004)
+ download_along (32946)
+ editgpx (33004)
+ ejml (32680)
+ geotools (33042)
+ imagery_offset_db (33004)
+ jts (32699)
+ measurement (33088)
+ opendata (33088)
+ osm-obj-info (1468276210)
+ pdfimport (33004)
+ photo_geotagging (33088)
+ rasterfilters (33088)
+ reltoolbox (33088)
+ tag2link (33035)
+ tageditor (33021)
+ todo (30000)
+ turnrestrictions (33088)
+ utilsplugin2 (33088)
+ wikipedia (33098)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/hiking_routes_with_trail_marking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Leaftype&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Addr2&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/caravan_site&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ %UserProfile%\Dropbox\GPS Files\Ways.xml
+ %UserProfile%\Dropbox\GPS Files\Bbl_Fuel.xml
+ %UserProfile%\Dropbox\GPS Files\Benchmark.xml
+ %UserProfile%\Dropbox\GPS Files\BorC.xml
+ %UserProfile%\Dropbox\GPS Files\Bridge.xml
+ %UserProfile%\Dropbox\GPS Files\CoinOp_Fuel.xml
+ %UserProfile%\Dropbox\GPS Files\Hamlet.xml
+ %UserProfile%\Dropbox\GPS Files\Land-Natural.xml
+ %UserProfile%\Dropbox\GPS Files\Milemarker.xml
+ %UserProfile%\Dropbox\GPS Files\NWR.xml
+ %UserProfile%\Dropbox\GPS Files\Ponds.xml
+ %UserProfile%\Dropbox\GPS Files\ResArea.xml
+ %UserProfile%\Dropbox\GPS Files\ResHwy.xml
+ %UserProfile%\Dropbox\GPS Files\Service.xml
+ %UserProfile%\Dropbox\GPS Files\Std_Fuel.xml
+ %UserProfile%\Dropbox\GPS Files\Stream.xml
+ %UserProfile%\Dropbox\GPS Files\tennis.xml
+ %UserProfile%\Dropbox\GPS Files\UnclassHwy.xml
+ %UserProfile%\Dropbox\GPS Files\US_Fuel.xml
+ %UserProfile%\Dropbox\GPS Files\Wat.xml
+ %UserProfile%\Dropbox\GPS Files\Waters.xml
+ %UserProfile%\Dropbox\GPS Files\wlan.xml
+ %UserProfile%\Dropbox\GPS Files\Daves-Misc.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://drone.io/bitbucket.org/stephankn/josm-thai-presets/files/target/josm-thai-presets.zip
+ %UserProfile%\Dropbox\GPS Files\address.xml

Last errors/warnings:
- W: Failed to open file with extension 'xml' and namepart 'preset' in zip file 'mirror_https___drone.io_bitbucket.org_stephankn_josm-thai-presets_files_target_josm-thai-presets.zip'. Exception was: java.util.zip.ZipException: error in opening zip file: java.util.zip.ZipException: error in opening zip file
- E: org.xml.sax.SAXParseException: The element type "link" must be terminated by the matching end-tag "</link>".
- E: https://drone.io/bitbucket.org/stephankn/josm-thai-presets/files/target/josm-thai-presets.zip
- E: Failed to locate image 'Flag, Blue'
- E: Failed to locate image 'Flag, Blue'
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@1fed2b7
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@9098ba
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@14bbbae
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@2bfe8d
- E: Handled by bug report queue: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
LayerManager#fireLayerAdded:
 - listener: org.openstreetmap.josm.plugins.rasterfilters.RasterFiltersPlugin@1df4536
 - event: LayerAddEvent [addedLayer=MarkerLayer [name=Markers from 2017-01-16 Chiang Mai to Nam Pat + WPs.gpx, associatedFile=C:\Users\Alask\Pictures\2017 Thailand Spring\2017-01-16 Udon Solo\2017-01-16 Chiang Mai to Nam Pat\2017-01-16 Chiang Mai to Nam Pat + WPs.gpx]]

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.rasterfilters.preferences.FiltersDownloader.downloadFiltersInfoList(FiltersDownloader.java:103)
	at org.openstreetmap.josm.plugins.rasterfilters.RasterFiltersPlugin.layerAdded(RasterFiltersPlugin.java:84)
	at org.openstreetmap.josm.gui.layer.LayerManager.fireLayerAdded(LayerManager.java:405)
	at org.openstreetmap.josm.gui.layer.LayerManager.realAddLayer(LayerManager.java:200)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realAddLayer(MainLayerManager.java:251)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$addLayer$0(LayerManager.java:189)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:189)
	at org.openstreetmap.josm.io.GpxImporter.lambda$addLayers$0(GpxImporter.java:121)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.WaitDispatchSupport$2.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.awt.WaitDispatchSupport$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.awt.WaitDispatchSupport.enter(Unknown Source)
	at java.awt.Dialog.show(Unknown Source)
	at java.awt.Component.show(Unknown Source)
	at java.awt.Component.setVisible(Unknown Source)
	at java.awt.Window.setVisible(Unknown Source)
	at java.awt.Dialog.setVisible(Unknown Source)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor.lambda$doBeginTask$3(PleaseWaitProgressMonitor.java:194)
	at org.openstreetmap.josm.gui.progress.PleaseWaitProgressMonitor.lambda$doInEDT$0(PleaseWaitProgressMonitor.java:60)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by skyper

Cc: michael2402 added
Component: CorePlugin rasterfilters
Keywords: gsoc-core regression added
Owner: changed from team to Nipel-Crumple

comment:2 Changed 3 years ago by skyper

Cc: michael2402 removed
Keywords: gsoc-core regression removed

comment:3 Changed 3 years ago by Don-vip

Description: modified (diff)
Resolution: duplicate
Status: newclosed

Closed as duplicate of #13534.
Fixed two weeks ago, please update your plugins.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Nipel-Crumple.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.