Modify

Opened 4 years ago

Closed 3 weeks ago

Last modified 3 weeks ago

#14200 closed defect (fixed)

Large node move

Reported by: pnorman Owned by: team
Priority: normal Milestone: 20.08
Component: Core Version: tested
Keywords: move node Cc:

Description (last modified by skyper)

Changesets 44908610, 44908677, 44909702, and 44909725

moved nodes 4450606777, 4502926154, 4524981479, and 4379443012 several thousand KM instead of adding tags to their parent way.

I don't know what sequence of actions the user did. Java9 was suggested as a possible cause.

The first one is perhaps the easiest to debug. The node moved was part of a building from a HOT project

Attachments (2)

JOSM Status Report.txt (21.3 KB) - added by scw2wi@… 4 years ago.
Status Report
2020-08-29-172656.png (5.9 KB) - added by simon04 3 weeks ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 4 years ago by skyper

Description: modified (diff)
Keywords: move node added

comment:2 Changed 4 years ago by Don-vip

Thanks Paul for reporting it. I have asked Walter to share his status report here. Did you see similar problem with other users?

comment:3 Changed 4 years ago by scw2wi@…

It happened 3 times to me (JOSM 11427) and I think it happens if I save during map is in overview (very low resolution).

Walter

comment:4 Changed 4 years ago by Don-vip

Could you please attach your status report and a screenshot of what you're doing when you think the error happens? Thanks.

comment:5 Changed 4 years ago by scw2wi@…

I am sorry but I did not notice the error at the same day, so I have no status report.
I made about 100 changes that day and at about 4 changes this error happened.
Since then it was not reproducible any more.

Walter

comment:6 Changed 4 years ago by Don-vip

A status report is still helpful as I would know your version of Java and how you launch JOSM.

Changed 4 years ago by scw2wi@…

Attachment: JOSM Status Report.txt added

Status Report

comment:7 Changed 4 years ago by pnorman

Did you see similar problem with other users?

http://www.openstreetmap.org/changeset/45228754 is another large node move from JOSM 11427.

comment:8 Changed 3 weeks ago by simon04

Resolution: fixed
Status: newclosed

In 16968/josm:

fix #14200 - Warn when moving elements by a large distance

Changed 3 weeks ago by simon04

Attachment: 2020-08-29-172656.png added

comment:9 Changed 3 weeks ago by simon04

Milestone: 20.08


comment:10 Changed 3 weeks ago by Klumbumbus

Does this make the MovementAlert plugin obsolet?

comment:11 Changed 3 weeks ago by simon04

Yes, likely. I wasn't aware of this plugin…

comment:12 Changed 3 weeks ago by simon04

In 16975/josm:

see #14200 - deprecate MovementAlert plugin

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.