Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#14198 closed defect (fixed)

Preset fo social_facility needs rework

Reported by: AB-inf-x-chg-AB@… Owned by: team
Priority: normal Milestone:
Component: External preset Version:
Keywords: Cc:

Description

Einige Information zum Thema sind zu finden unter:
https://forum.openstreetmap.org/viewtopic.php?id=56893

Eine Zusatzinfo, der merkwürdige Eintrag "social_facility:for"=" disabled person " erscheint, wahrscheinlich nur, wenn man an einem bestehenden Objekt (mit "social_facility:for"="disabled") eine Änderung vornehmen möchte, oder eben wenn man vom Validator darum gebeten wird.

Attachments (0)

Change History (9)

comment:1 Changed 2 years ago by skyper

Component: Core validatorInternal preset
Summary: Vorlage >> Einrichtung >> Sozialeinrichtung prüfen und ggf. verändernPreset fo social_facility needs rework

@team:
What do we do with tickets for several "components" like validator and internal preset for this ticket ?

  1. the internal preset needs some rework.
  2. validator should autofix social_facility:for=disabled person to social_facility:for=disabled
Last edited 2 years ago by skyper (previous) (diff)

comment:2 Changed 2 years ago by anonymous

Hi skyper,

thanks for checking this ticket.
And also thanks for correcting the request by selecting the right component. I didn't know the details...

AB

comment:3 Changed 2 years ago by Klumbumbus

Component: Internal presetExternal preset

Thats not part of the internal preset; it is from Presets/NewTags.
Everyone can edit these wiki based presets (even non logged in users). AB-inf-x-chg-AB do you want to fix this yourself?

As there are only 44 objects with social_facility:for=disabled person taginfo I don't think we need a validator rule here. Checking and fixing this once should be safe as the value with the space is clearly a wrong value.


What do we do with tickets for several "components" like validator and internal preset for this ticket ?

Just choose the one which fits best/most.

comment:4 in reply to:  3 Changed 2 years ago by Don-vip

What do we do with tickets for several "components" like validator and internal preset for this ticket ?

Just choose the one which fits best/most.

https://trac.edgewall.org/ticket/221 would allow us to affect multiple components, but the issue is open for 13 years...

comment:5 Changed 2 years ago by anonymous

Hi Klumbumbus,

That’s not part of the internal preset; it is from Presets/NewTags.
Everyone can edit these wiki based presets (even non logged in users). AB-inf-x-chg-AB do you want to fix this yourself?

I would like to do, but I'm not sure, if I have the knowledge to do this.
I found this wiki(did not read yet): https://josm.openstreetmap.de/wiki/De%3APresets
Is this all I need to know? Or there are other needed helpful manuals and instructions?

Regards
AB

comment:6 in reply to:  5 Changed 2 years ago by Klumbumbus

Replying to anonymous:

I found this wiki(did not read yet): https://josm.openstreetmap.de/wiki/De%3APresets
Is this all I need to know?

Yes. And the docu of the preset xml schema is at De:TaggingPresets. However you don't relly need to read both. Just edit the Presets/NewTags wikipage search for disabled person and you will see, what you need to change. It's really easy.

comment:7 Changed 2 years ago by anonymous

Yes. And the docu of the preset xml schema is at De:TaggingPresets. However you don't relly need to read both. Just edit the Presets/NewTags wikipage search for disabled person and you will see, what you need to change. It's really easy.

Hi Klumbumbus,
thanks for the link to the preset xml schema.
Yesterday I tested the modification it for a Presets_NewTags.zip >> Presets_NewTags-preset.xml a my local PC, and JOSM did show expected behavior.
Now I did also the modification of 8 strings from "disabled person" to "disabled" at web-stored Presets/NewTags.
By the way, do you know when the web Presets/NewTags will be synchronized with JOSM, or in other words at which time / at which version will JOSM use the modified Presets/NewTags?
What is the plan for the 44 wrong objects "social_facility:for=disabled person" taginfo:http://taginfo.openstreetmap.org/keys/social_facility%3Afor#values in the planet database?
Regards
AB

comment:8 in reply to:  7 Changed 2 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

Replying to anonymous:

do you know when the web Presets/NewTags will be synchronized with JOSM?

See De:Presets/#VorlageninJOSMaktualisieren

What is the plan for the 44 wrong objects "social_facility:for=disabled person" taginfo:http://taginfo.openstreetmap.org/keys/social_facility%3Afor#values in the planet database?

I fixed them.

comment:9 Changed 2 years ago by AB

Hi Klumbumbus,

thanks for the link De:Presets/#VorlageninJOSMaktualisieren - enforced instant sync worked well by following the 8 steps from this wiki.
Also, thanks for cleaning planet-db with wrong values, and closing the ticket :-)

Regards
AB

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.