Modify

Opened 5 years ago

Closed 5 years ago

#14189 closed defect (duplicate)

Problem with plugins update

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-12-31 17:39:03 +0100 (Sat, 31 Dec 2016)
Build-Date:2016-12-31 17:38:24
Revision:11425
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11425 fr) Linux Ubuntu 16.04.1 LTS
Memory Usage: 263 MB / 876 MB (87 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-2ubuntu0.16.04.2-b14, Oracle Corporation, OpenJDK Server VM
Screen: :0.0 1600x900
Maximum Screen Size: 1600x900
Java package: openjdk-8-jre:i386-8u111-b14-2ubuntu0.16.04.2
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
+ cadastre-fr
+ ejml
+ geotools
+ jts

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.. Cause : java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.. Cause : org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.
	at org.openstreetmap.josm.Main.initialize(Main.java:563)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:336)
Caused by: java.util.concurrent.ExecutionException: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at org.openstreetmap.josm.Main.initialize(Main.java:555)
	... 1 more
Caused by: org.openstreetmap.josm.tools.JosmRuntimeException: Join areas internal error.
	at org.openstreetmap.josm.actions.JoinAreasAction.findBoundaryPolygons(JoinAreasAction.java:1170)
	at org.openstreetmap.josm.actions.JoinAreasAction.joinAreas(JoinAreasAction.java:647)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.computeOptimizedBoundaries(RightAndLefthandTraffic.java:112)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.initialize(RightAndLefthandTraffic.java:67)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:602)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:586)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by skyper

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14185.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.