Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14154 closed defect (duplicate)

Enabling Remote Control + HTTPS causes exceptions

Reported by: erickdeoliveiraleal Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report javabug Cc:

Description

What steps will reproduce the problem?

  1. Activate HTTPS support

What is the expected result?

Run smoothly

What happens instead?

After save a dialog with exception and also in every start.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-12-21 19:34:36 +0100 (Wed, 21 Dec 2016)
Build-Date:2016-12-22 02:32:16
Revision:11410
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11410 pt_BR) Windows 10 64-Bit
Memory Usage: 132 MB / 247 MB (31 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ michigan_left (33004)
+ reverter (33088)
+ tageditor (33021)
+ todo (30000)
+ turnrestrictions (33088)
+ utilsplugin2 (33088)

Map paint styles:
+ https://github.com/hotosm/HDM-JOSM-style/archive/master.zip

Last errors/warnings:
- E: Handled by bug report queue: java.lang.ArrayIndexOutOfBoundsException: 0


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.ArrayIndexOutOfBoundsException: 0
	at sun.security.mscapi.KeyStore.engineGetCertificateAlias(KeyStore.java:634)
	at sun.security.mscapi.KeyStore$ROOT.engineGetCertificateAlias(KeyStore.java:61)
	at java.security.KeyStore.getCertificateAlias(Unknown Source)
	at org.openstreetmap.josm.tools.PlatformHookWindows.setupHttpsCertificate(PlatformHookWindows.java:330)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.setupPlatform(RemoteControlHttpsServer.java:306)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.initialize(RemoteControlHttpsServer.java:290)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.<init>(RemoteControlHttpsServer.java:375)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControlHttpsServer.restartRemoteControlHttpsServer(RemoteControlHttpsServer.java:320)
	at org.openstreetmap.josm.io.remotecontrol.RemoteControl.start(RemoteControl.java:49)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:373)

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13855.

comment:2 Changed 6 years ago by skyper

Keywords: javabug added

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.