Modify

Opened 8 years ago

Closed 8 years ago

#14071 closed defect (invalid)

Photo Geotagging plugin crashes

Reported by: hjart Owned by: bastiK
Priority: normal Milestone:
Component: Plugin photo_geotagging Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

After having used the PhotoAdjust plugin to adjust coordinates and direction for a few images, I want to write the new info to said images using the Photo Geotagging plugin, which unfortunately then crashes when activated.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-11-06 20:18:38 +0100 (Sun, 06 Nov 2016)
Build-Date:2016-11-06 21:45:03
Revision:11223
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11223 da) Linux openSUSE Leap 42.2
Memory Usage: 1436 MB / 1436 MB (712 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1200
Maximum Screen Size: 1920x1200
Java package: openjdk-8-jre:pakken openjdk-8-jre er ikke installeret

Plugins:
+ DirectUpload (32699)
+ FastDraw (32938)
+ ImproveOsm (83)
+ InfoMode (32789)
+ Mapillary (v1.3.1)
+ SimplifyArea (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32944)
+ ejml (32680)
+ geotools (33042)
+ jts (32699)
+ opendata (33049)
+ photo_geotagging (33088)
+ photoadjust (32863)
+ reverter (32796)
+ tagging-preset-tester (32869)
+ todo (30000)
+ utilsplugin2 (32815)
+ wikipedia (33017)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ http://www.country-linedance.de/daten/Archaeologie-de.zip
+ ${HOME}/Dokumenter/HjartsPresets.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1

Last errors/warnings:
- E: Mapillary download interrupted (probably because of closing the layer).
- E: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v2/search/im/or?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&min_lon=10.085889&max_lat=56.048261&max_lon=10.093067&limit=20&page=7&min_lat=56.045276
- W: java.net.SocketException: Socket closed
- E: java.net.SocketException: Socket closed
- W: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled. Årsag: org.openstreetmap.josm.io.OsmTransferException: Kunne ikke forbinde til osm serveren. Tjek din internetforbindelse.. Årsag: java.net.SocketException: Socket closed
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: Invalid jar file ''<josm.pref>/plugins/photo_geotagging.jar.new'' (exists: false, canRead: false)
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: org/apache/commons/imaging/formats/tiff/taginfos/TagInfoBytes. Årsag: java.lang.ClassNotFoundException: org.apache.commons.imaging.formats.tiff.taginfos.TagInfoBytes


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main-worker-0 (121)
java.lang.NoClassDefFoundError: org/apache/commons/imaging/formats/tiff/taginfos/TagInfoBytes
	at org.openstreetmap.josm.plugins.photo_geotagging.GeotaggingAction$GeoTaggingRunnable.realRun(GeotaggingAction.java:231)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.imaging.formats.tiff.taginfos.TagInfoBytes
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	... 6 more

Attachments (0)

Change History (2)

in reply to:  description comment:1 by skyper, 8 years ago

Replying to hjart:

- W: Invalid jar file ''<josm.pref>/plugins/photo_geotagging.jar.new'' (exists: false, canRead: false)
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: org/apache/commons/imaging/formats/tiff/taginfos/TagInfoBytes. Årsag: java.lang.ClassNotFoundException: org.apache.commons.imaging.formats.tiff.taginfos.TagInfoBytes

This looks strange.

  • Did you switch between latest and testing version ?
  • Do you have any "josm-plugins-package" from your distribution installed ?
  • Could you try it with a new preferences ? See Help/CommandLineOptions#JOSMJVMoptions.

comment:2 by hjart, 8 years ago

Resolution: invalid
Status: newclosed

@skyper
I did in fact use latest for years, but found it too unusable for daily work for a while and neglected switching back to test this. Sorry about that.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain bastiK.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.