Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14005 closed defect (fixed)

Stuck at imagery loading after update

Reported by: muzirian Owned by: team
Priority: normal Milestone: 16.12
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. download old jar and plugins
  2. download new jar and replace old one
  3. launch the new jar, allow to update plugins

What is the expected result?

open josm nonrmally

What happens instead?

hanged at loading imagery preferences and prompts me to file a bug report

Please provide any additional information below. Attach a screenshot if possible.

this occured for 2 or 3 times , but now its opening normally.
Im reporting this bug only because josm asked me to

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-11-18 22:42:23 +0100 (Fri, 18 Nov 2016)
Build-Date:2016-11-19 02:35:18
Revision:11283
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11283 en) Windows 7 64-Bit
Memory Usage: 70 MB / 247 MB (7 MB allocated, but free)
Java version: 1.8.0_51-b16, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1280x800
Maximum Screen Size: 1280x800

Plugins:
+ DirectDownload
+ FastDraw
+ buildings_tools
+ download_along
+ editgpx
+ geochat
+ imagery_offset_db
+ log4j (32699)
+ openvisible
+ reltoolbox
+ splinex
+ utilsplugin2
+ walkingpapers

Last errors/warnings:
- W: java.util.zip.ZipException: error in opening zip file
- W: PluginException: : org.openstreetmap.josm.plugins.PluginException: Invalid jar file '<josm.pref>\plugins\areaselector.jar.new'
- W: Failed to scan file 'areaselector.jar.new' for plugin information. Skipping.
- W: Failed to install plugin '<josm.pref>\plugins\areaselector.jar' from temporary download file '<josm.pref>\plugins\areaselector.jar.new'. error in opening zip file: java.util.zip.ZipException: error in opening zip file
- E: Handled by bug report queue: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Cause: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Cause: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at org.openstreetmap.josm.Main.initialize(Main.java:545)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:336)
Caused by: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at java.util.concurrent.FutureTask.report(Unknown Source)
	at java.util.concurrent.FutureTask.get(Unknown Source)
	at org.openstreetmap.josm.Main.initialize(Main.java:537)
	... 1 more
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.data.osm.DataSet.<init>(DataSet.java:143)
	at org.openstreetmap.josm.tools.Territories.getDataSet(Territories.java:89)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.computeOptimizedBoundaries(RightAndLefthandTraffic.java:77)
	at org.openstreetmap.josm.tools.RightAndLefthandTraffic.initialize(RightAndLefthandTraffic.java:67)
	at org.openstreetmap.josm.Main$$Lambda$81/31373259.run(Unknown Source)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:584)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:568)
	at java.util.concurrent.FutureTask.run(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:2 Changed 3 years ago by michael2402

Resolution: fixed
Status: newclosed

In 11284/josm:

Fix #14005: Initialize Territories before RightAndLefthandTraffic

comment:3 Changed 3 years ago by Klumbumbus

Milestone: 16.11

comment:4 Changed 3 years ago by Don-vip

Milestone: 16.1116.12

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.