Modify

Opened 2 years ago

Closed 3 weeks ago

#13912 closed defect (duplicate)

AssertionError: Primitive was removed when purging, but is still there on undo

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

With the attached file, I selected both ways, purged (with Clear Undo/Redo buffer unchecked)
Then downloaded the same area back from OSM and pressed Ctrl+Z 2 times. Got this crash.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-11-01 23:23:54 +0100 (Tue, 01 Nov 2016)
Build-Date:2016-11-02 02:32:44
Revision:11209
Relative:URL: ^/trunk

Identification: JOSM/1.5 (11209 en) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 247 MB / 10206 MB (80 MB allocated, but free)
Java version: 1.8.0_111-8u111-b14-2-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java package: openjdk-8-jre:amd64-8u111-b14-2
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-9
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
+ Create_grid_of_ways (32699)
+ FastDraw (32938)
+ ImportImagePlugin (32699)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ RoadSigns (32796)
+ SimplifyArea (32796)
+ apache-commons (32699)
+ buildings_tools (32944)
+ conflation (0.3.0)
+ contourmerge (1030)
+ download_along (32946)
+ editgpx (32699)
+ ejml (32680)
+ geojson (43)
+ geotools (33042)
+ importvec (32699)
+ indoorhelper (32680)
+ jts (32699)
+ log4j (32699)
+ measurement (32936)
+ merge-overlap (32699)
+ opendata (33040)
+ pbf (32865)
+ pdfimport (32796)
+ poly (32699)
+ reverter (32796)
+ scripting (30761)
+ tageditor (33021)
+ todo (30000)
+ turnlanes (32796)
+ turnlanes-tagging (252)
+ turnrestrictions (32796)
+ undelete (32699)
+ utilsplugin2 (32815)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- <josm.pref>/styles/indoor.mapcss
- https://dl.dropbox.com/u/8010189/Forum%20attachments/Hide_nodes.mapcss

Validator rules:
+ /arquivos/git/validador-josm/Rules_Brazilian-Specific.validator.mapcss
+ /arquivos/git/validador-josm/staging.validator.mapcss
- <josm.pref>/validator/indoorhelper.validator.mapcss

Last errors/warnings:
- W: Cannot start IPv4 remotecontrol server on port 8111: Address already in use (Bind failed)
- W: Cannot start IPv6 remotecontrol server on port 8111: Address already in use (Bind failed)
- W: Cannot start IPv4 remotecontrol https server on port 8112: Address already in use (Bind failed)
- W: Cannot start IPv6 remotecontrol https server on port 8112: Address already in use (Bind failed)
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@314e2ec3
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@670782da
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@5deb058
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@a540181
- E: Handled by bug report queue: org.openstreetmap.josm.tools.bugreport.ReportedException: java.lang.AssertionError: Primitive {Node id=2596061493 version=1 V lat=-23.500156,lon=-46.725131} was removed when purging, but is still there on undo. Cause: java.lang.AssertionError: Primitive {Node id=2596061493 version=1 V lat=-23.500156,lon=-46.725131} was removed when purging, but is still there on undo


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.AssertionError: Primitive {Node id=2596061493 version=1 V lat=-23.500156,lon=-46.725131} was removed when purging, but is still there on undo
	at org.openstreetmap.josm.command.PurgeCommand.undoCommand(PurgeCommand.java:135)
	at org.openstreetmap.josm.data.UndoRedoHandler.undo(UndoRedoHandler.java:114)
	at org.openstreetmap.josm.data.UndoRedoHandler.undo(UndoRedoHandler.java:98)
	at org.openstreetmap.josm.actions.UndoAction.actionPerformed(UndoAction.java:36)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1663)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2882)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:263)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2974)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2966)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2845)
	at java.awt.Component.processEvent(Component.java:6310)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:806)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1074)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:945)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:771)
	at java.awt.Component.dispatchEventImpl(Component.java:4760)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (1)

error.osm (5.5 KB) - added by naoliv 2 years ago.

Download all attachments as: .zip

Change History (2)

Changed 2 years ago by naoliv

Attachment: error.osm added

comment:1 Changed 3 weeks ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11333.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.