Modify

Opened 6 years ago

Closed 6 years ago

#13906 closed defect (duplicate)

plugin "Cadastre-fr" while using address tool

Reported by: anonymous Owned by: pieren
Priority: major Milestone:
Component: Plugin cadastre-fr Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. just using the "address tool" from "Cadastre-fr" tool (https://wiki.openstreetmap.org/wiki/FR:JOSM/Greffons/Cadastre-fr)

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 fr) Linux Ubuntu 16.04.1 LTS
Memory Usage: 728 MB / 1756 MB (229 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-3ubuntu1~16.04.1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u91-b14-3ubuntu1~16.04.1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-6
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ apache-commons (32699)
+ apache-http (32699)
+ cadastre-fr (32950)
+ ejml (32680)
+ geotools (33042)
+ jts (32699)
+ photo_geotagging (32699)
+ photoadjust (32863)
+ tag2link (33035)

Tagging presets:
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/CampingForOverlanders&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Camp_site_extends&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/AdvertisingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Maxspeed-zones&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/MobilePhoneBaseStations&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/FR.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Surveillance&zip=1

Last errors/warnings:
- E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
- E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]
- E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
- E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]
- E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
- E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]
- E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
- E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]
- E: Le modèle d’attributs 'historic-Type of historic' n’est pas valide - 'display_values' doit avoir le même nombre d’éléments que 'values'
- E: Information détaillée: [heritage, site archéologique, borne frontière, château, porte de ville, fort, mémorial, monument commémoratif] <> [archaeological_site, boundary_stone, castle, city_gate, fort, memorial, monument]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.IllegalArgumentException: Listener cadastre_fr.Address@33ef268f (instance of cadastre_fr.Address) was not registered before or already removed.
	at org.openstreetmap.josm.tools.ListenerList.failRemove(ListenerList.java:129)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.failRemove(ListenerList.java:206)
	at org.openstreetmap.josm.tools.ListenerList.removeListener(ListenerList.java:123)
	at org.openstreetmap.josm.tools.ListenerList$TracingListenerList.removeListener(ListenerList.java:190)
	at org.openstreetmap.josm.data.Preferences.removePreferenceChangeListener(Preferences.java:238)
	at org.openstreetmap.josm.actions.mapmode.MapMode.exitMode(MapMode.java:78)
	at cadastre_fr.Address.exitMode(Address.java:113)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:450)
	at org.openstreetmap.josm.gui.MapFrame.selectMapMode(MapFrame.java:432)
	at cadastre_fr.Address$4.windowClosing(Address.java:513)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:350)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.AWTEventMulticaster.windowClosing(AWTEventMulticaster.java:349)
	at java.awt.Window.processWindowEvent(Window.java:2058)
	at javax.swing.JDialog.processWindowEvent(JDialog.java:683)
	at java.awt.Window.processEvent(Window.java:2017)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by anonymous

Component: CorePlugin cadastre-fr
Owner: changed from team to pieren
Priority: normalmajor

comment:2 Changed 6 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13863.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain pieren.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.