Modify

Opened 8 years ago

Closed 8 years ago

#13836 closed defect (duplicate)

GPS

Reported by: anonymous Owned by: framm
Priority: normal Milestone:
Component: Plugin livegps Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Click on GPS/GPS-Spur aufzeichnen

What is the expected result?

dont know what, but no error

What happens instead?

error

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 de) Linux Ubuntu 14.04.5 LTS
Memory Usage: 283 MB / 444 MB (69 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: :0.0 1280x800
Maximum Screen Size: 1280x800
Dataset consistency test: No problems found

Plugins:
+ ElevationProfile (32868)
+ FixAddresses (32796)
+ HouseNumberTaggingTool (32699)
+ Mapillary (v1.3.1)
+ OpeningHoursEditor (32699)
+ SeaMapEditor (32767)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32944)
+ download_along (32946)
+ imagery_offset_db (32796)
+ indoorhelper (32680)
+ livegps (32954)
+ measurement (32936)
+ public_transport (32796)
+ public_transport_layer (32817)
+ reverter (32796)
+ todo (30000)
+ undelete (32699)
+ utilsplugin2 (32815)

Tagging presets:
+ http://zibi.openstreetmap.org.pl/kendzi/k/Simple3dPreset/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ http://michreichert.de/osm/wochenaufgabe/wa0607-apotheken/apotheken.xml
+ ${HOME}/OSM/OpenRailwayMap-master/josm-presets/de-signals-hha.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Diving&zip=1
+ http://www.freietonne.de/ft_icons/josm/FreieTonne_rules_presets_zip.php
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT-1-preset.xml
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Sport.xml
+ http://www.openrailwaymap.org/josm-presets/de-signals-eso.zip
+ http://www.openrailwaymap.org/josm-presets/de.zip
+ http://www.openrailwaymap.org/josm-presets/de-signals-bostrab.zip
+ http://www.openrailwaymap.org/josm-presets/de-avg-signals.zip
+ https://raw.githubusercontent.com/jacobbraeutigam/JOSM_Preset_street_cabinet/master/street_cabinet.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ http://openstationmap.org/0.2.0/datamodel/JOSM-preset-OpenStationMap-LoD.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/CommonKeyboardShortcuts&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ http://www.openrailwaymap.org/styles/standard.mapcss
+ http://www.openrailwaymap.org/styles/maxspeed.mapcss
+ http://www.openrailwaymap.org/styles/signals.mapcss
- http://www.openrailwaymap.org/styles/josm-additional.mapcss
- http://www.freietonne.de/ft_icons/josm/FreieTonne_rules_presets_zip.php
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/Seamark.validator.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1

Validator rules:
+ http://www.openrailwaymap.org/validator/de-openrailwaymap.validator.mapcss
+ http://www.openrailwaymap.org/validator/openrailwaymap.validator.mapcss

Last errors/warnings:
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'
- E: Fehler beim Laden des Bildes 'icons/level-crossing-24.png'


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.ExceptionInInitializerError
	at livegps.LiveGpsPlugin.enableTracking(LiveGpsPlugin.java:173)
	at livegps.LiveGpsPlugin$CaptureAction.actionPerformed(LiveGpsPlugin.java:55)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.JToggleButton$ToggleButtonModel.setPressed(JToggleButton.java:308)
	at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
	at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
	at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6535)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6300)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.IllegalArgumentException: Listener PreferenceChangedListenerAdapter [listener=org.openstreetmap.josm.data.preferences.CachingProperty@4746584] (instance of org.openstreetmap.josm.data.preferences.AbstractProperty$PreferenceChangedListenerAdapter) was already registered.
	at org.openstreetmap.josm.tools.ListenerList.failAdd(ListenerList.java:108)
	at org.openstreetmap.josm.tools.ListenerList.ensureNotInList(ListenerList.java:102)
	at org.openstreetmap.josm.tools.ListenerList.addWeakListener(ListenerList.java:82)
	at org.openstreetmap.josm.data.Preferences.addWeakKeyPreferenceChangeListener(Preferences.java:258)
	at org.openstreetmap.josm.data.preferences.AbstractProperty.addWeakListenerImpl(AbstractProperty.java:249)
	at org.openstreetmap.josm.data.preferences.AbstractProperty.addWeakListener(AbstractProperty.java:245)
	at org.openstreetmap.josm.data.preferences.CachingProperty.<init>(CachingProperty.java:27)
	at org.openstreetmap.josm.data.preferences.AbstractToStringProperty.cached(AbstractToStringProperty.java:159)
	at livegps.LiveGpsLayer.<clinit>(LiveGpsLayer.java:34)
	... 41 more

Attachments (0)

Change History (2)

comment:1 by bastiK, 8 years ago

Component: CorePlugin livegps
Owner: changed from team to framm

comment:2 by Don-vip, 8 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13789.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.