Modify

Opened 3 years ago

Closed 3 years ago

#13711 closed enhancement (duplicate)

No tag-correction prompt when reversing ways that contain nodes with "direction"-tag

Reported by: merten@… Owned by: team
Priority: major Milestone:
Component: Core Version:
Keywords: direction, node, reverse, automatic Cc:

Description

There are nodes which can have the "direction"-tag, such as highway=traffic_signals/give_way/stop to indicate that they only apply in one direction relative to the way that contains it. Currently in JOSM when such a way is reversed with the "Reverse Ways" tool, no prompt is shown and the node does still have the same (now wrong) "direction"-tag. This could potentially confuse routing apps when mappers change ways without checking all nodes with the "direction"-tag.

I recommend showing a prompt in these cases, similar to the "Automatic tag correction" prompt when reversing a one-way-way. It should contain the problematic nodes instead.

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by skyper

Again the broken system of wrong values for direction=* on nodes. This will never work. Use proper values or a relation.

comment:2 Changed 3 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #10260.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.