Modify

Opened 3 years ago

Closed 4 weeks ago

#13671 closed defect (fixed)

NPE at SelectBoundaryAction when Josm Filter Function is used

Reported by: miluethi Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Use the filter function -> admin_level=? instead of admin_level=6 or admin_level=8 produces this error.

What is the expected result?

What is the placeholder in filter function for any number? A "good" josm response would be: Use "#" as placeholder, "?" is not valid.

What happens instead?

It produces an error message.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 en) Windows 10 64-Bit
Memory Usage: 1646 MB / 7111 MB (338 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 3840x2160
Maximum Screen Size: 3840x2160

Dataset consistency test:
[WARN - NO NODES] Way {Way id=421121483 version=3 VT nodes=[{Node id=254200976 version=3 V lat=40.9501027,lon=-73.740999}]} has only one node
[WARN - NO NODES] Way {Way id=421170816 version=2 VT> nodes=[{Node id=2481879586 version=1 V lat=40.9218219,lon=-73.7720353}]} has only one node


Plugins:
+ CustomizePublicTransportStop (0.3)
+ DxfImport (1008)
+ FixAddresses (32796)
+ HouseNumberTaggingTool (32699)
+ RoadSigns (32796)
+ ShapeTools (1220)
+ apache-commons (32699)
+ continuosDownload (53)
+ editgpx (32699)
+ ejml (32680)
+ geojson (43)
+ geotools (32813)
+ globalsat (32796)
+ gson (32680)
+ jts (32699)
+ log4j (32699)
+ opendata (32898)
+ photo_geotagging (32699)
+ public_transport (32796)
+ public_transport_layer (32817)
+ routing (32796)
+ utilsplugin2 (32815)
+ waypoint_search (32699)
+ wikipedia (32884)

Last errors/warnings:
- E: Cannot load library rxtxSerial. If you need support to install it try Globalsat homepage at http://www.raphael-mack.de/josm-globalsat-gpx-import-plugin/
- E: java.io.IOException: Stream closed
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- E: java.io.IOException: Stream closed
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>
- E: java.io.IOException: Stream closed
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400, Error Header=<You requested too many nodes (limit is 50000). Either request a smaller area, or use planet.osm>, Error Body=<Reading error text failed.>
- E: Bad Request - <html>The OSM server 'api.openstreetmap.org' reported a bad request.<br><br>The area you tried to download is too big or your request was too large.<br>Either request a smaller area or use an export file provided by the OSM community.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (21) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.utilsplugin2.selection.SelectBoundaryAction.actionPerformed(SelectBoundaryAction.java:58)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (6)

comment:1 Changed 3 years ago by simon04

Component: CorePlugin utilsplugin2

comment:2 Changed 3 years ago by Klumbumbus

Summary: Josm Filter FunctionNPE at SelectBoundaryAction when Josm Filter Function is used

The correct placeholder is * as you can see in the add filter window.

comment:3 Changed 3 years ago by miluethi

Thank you, I figured that out too. But Josm is producing an error if I use the "?" and it probably should not do it.

comment:4 Changed 3 years ago by Klumbumbus

Yes, therefore this ticket is still open :)

comment:5 Changed 4 weeks ago by Don-vip

Ticket #18069 has been marked as a duplicate of this ticket.

comment:6 Changed 4 weeks ago by Don-vip

Resolution: fixed
Status: newclosed

Fixed in [o35098:35099].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.