Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13659 closed defect (duplicate)

Leider gibt es jetzt ständig Konflikte die aufgelöst werden müssen. In unangetasteten (!) Gebieten. Änderungen lassen sich nicht hochladen.

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 de) Windows 10 64-Bit
Memory Usage: 403 MB / 989 MB (52 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Dataset consistency test:
[WARN - ZERO NODES] Way {Way id=143735226 version=1 MVT nodes=[]} has zero nodes


Plugins:
+ AddrInterpolation (32699)
+ FastDraw (32938)
+ OpeningHoursEditor (32699)
+ RoadSigns (32796)
+ alignways (32921)
+ buildings_tools (32944)
+ contourmerge (1022)
+ geochat (32796)
+ print (32699)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)
+ wikipedia (32884)

Last errors/warnings:
- W: java.net.SocketTimeoutException: Read timed out
- E: Error header: Precondition failed: Node 1163228697 is still used by ways 100616606.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 1163228697 is still used by ways 100616606.>
- E: Objekt wird noch benutzt - <html>Löschen des <strong>Punktes 1163228697</strong> <strong fehlgeschlagen</strong>. Er wird von Linie 100616606 weiterhin verwendet.<br>Bitte die Linie herunterladen, die Referenz auf den Punkt entfernen und erneut hochladen.<br><br>Zum Herunterladen <strong>Bereinigen von Konflikten vorbereiten</strong> anklicken.<br>Falls notwendig werden Konflikte erstellt, welche im Dialog zur Konfliktlösung behoben werden können.</html>
- W: Konflikte gefunden - <html>4 Konflikte wurden entdeckt.</html>
- W: Achtung - <html>Daten, die hochgeladen werden sollen, sind an Konflikten in der Ebene 'Datenebene 1' beteiligt.<br>Sie müssen diese zunächst auflösen.</html>
- E: Error header: Precondition failed: Node 15724540 is still used by ways 3220272.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 15724540 is still used by ways 3220272.>
- E: Objekt wird noch benutzt - <html>Löschen des <strong>Punktes 15724540</strong> <strong fehlgeschlagen</strong>. Er wird von Linie 3220272 weiterhin verwendet.<br>Bitte die Linie herunterladen, die Referenz auf den Punkt entfernen und erneut hochladen.<br><br>Zum Herunterladen <strong>Bereinigen von Konflikten vorbereiten</strong> anklicken.<br>Falls notwendig werden Konflikte erstellt, welche im Dialog zur Konfliktlösung behoben werden können.</html>
- W: Konflikte gefunden - <html>4 Konflikte wurden entdeckt.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
java.lang.IllegalArgumentException: {Node id=278488646 version=7 MVD lat=53.48030377326245,lon=9.881053993254088} is already deleted
	at org.openstreetmap.josm.command.DeleteCommand.executeCommand(DeleteCommand.java:156)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:54)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:52)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:85)
	at org.openstreetmap.josm.actions.mapmode.DeleteAction.doActionPerformed(DeleteAction.java:153)
	at org.openstreetmap.josm.actions.DeleteAction.actionPerformed(DeleteAction.java:34)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13658.

comment:2 Changed 3 years ago by Klumbumbus

maybe duplicate of #6529

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.