Modify

Opened 3 years ago

Closed 3 years ago

#13638 closed defect (duplicate)

Overpass API download

Reported by: pschonmann Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Try build and download place~"(hamlet|village|suburb|town|locality|neighbourhood)" and type:node and wikipedia!~"cs.*" in "Czech Republic"
  2. Youll get info that overpass api reported bad request

What is the expected result?

Download requested data

What happens instead?

Error, see below.

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 cs) Windows 10 64-Bit
Memory Usage: 1046 MB / 3637 MB (803 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1200
Maximum Screen Size: 1920x1200

Plugins:
+ BuildingGeneralization (1010)
+ Mapillary (32988)
+ OpeningHoursEditor (32699)
+ Tracer-testing (32699)
+ apache-commons (32699)
+ apache-http (32699)
+ auto_tools (1471534390)
+ buildings_tools (32944)
+ download_along (32946)
+ editgpx (32699)
+ ejml (32680)
+ geotools (32813)
+ imagery_offset_db (32796)
+ imageryadjust (32699)
+ jts (32699)
+ opendata (32898)
+ pointInfo (32870)
+ turnlanes-tagging (245)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)
+ waydownloader (32699)
+ waypoint_search (32699)
+ wikipedia (32884)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Czech_hiking&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/SentieriItaliani&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Trees&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/CommonKeyboardShortcuts&zip=1

Map paint styles:
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1

Validator rules:
+ https://josm.openstreetmap.de/josmfile?page=Rules/CzechRepublicAddressSystem&zip=1
+ https://raw.githubusercontent.com/stefan-a-bauer/josm-validators/master/mtb.validator.mapcss

Last errors/warnings:
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400
- E: Špatný požadavek - <html>OSM server 'overpass-api.de' reportoval špatný požadavek.<br></html>

SEVERE: org.openstreetmap.josm.io.OsmApiException: ResponseCode=400
org.openstreetmap.josm.io.OsmApiException: ResponseCode=400
        at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:163)
        at org.openstreetmap.josm.io.OverpassDownloadReader.getInputStreamRaw(OverpassDownloadReader.java:95)
        at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:97)
        at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:61)
        at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:44)
        at org.openstreetmap.josm.io.BoundingBoxDownloader.parseOsm(BoundingBoxDownloader.java:186)
        at org.openstreetmap.josm.io.OverpassDownloadReader.parseOsm(OverpassDownloadReader.java:149)
        at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.parseDataSet(DownloadOsmTask.java:312)
        at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$DownloadTask.realRun(DownloadOsmTask.java:320)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
        at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:141)
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
        at java.util.concurrent.FutureTask.run(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
        at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by naoliv

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11975.
Right now it doesn't support extended queries (the in "Czech Republic" part from your example)
See #11975 where it's being discussed and implemented.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.