Modify

Opened 3 years ago

Closed 13 months ago

#13623 closed defect (duplicate)

delete "cycle routes" layer caused NPE at SaveLayersDialog$SaveAndProceedAction

Reported by: ardisphere@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. highlight a layer in the Layers panel
  2. click the "delete the selected layers"

What is the expected result?

Layer should delete

What happens instead?

"unexpected exception" window

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 en) Linux Ubuntu 16.04.1 LTS
Memory Usage: 415 MB / 852 MB (166 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-3ubuntu1~16.04.1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 1920x1080
Maximum Screen Size: 1920x1080
Java package: openjdk-8-jre:amd64-8u91-b14-3ubuntu1~16.04.1
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ CommandLine (32796)
+ FastDraw (32938)
+ ImportImagePlugin (32699)
+ ImproveWay (1452443304)
+ PicLayer (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ areaselector (282)
+ auto_tools (1471534390)
+ buildings_tools (32944)
+ continuosDownload (53)
+ download_along (32946)
+ ejml (32680)
+ geotools (32813)
+ importvec (32699)
+ jogl (1.0.46)
+ jts (32699)
+ log4j (32699)
+ measurement (32936)
+ merge-overlap (32699)
+ namemanager (32699)
+ o5m (32857)
+ osm-obj-info (1468276210)
+ osmarender (32699)
+ pbf (32865)
+ pdfimport (32796)
+ plastic_laf (32699)
+ poly (32699)
+ print (32699)
+ pt_assistant (32990)
+ public_transport (32796)
+ public_transport_layer (32817)
+ reltoolbox (32796)
+ reverter (32796)
+ routes (32842)
+ routing (32796)
+ tageditor (32796)
+ terracer (32699)
+ undelete (32699)
+ utilsplugin2 (32815)
+ waydownloader (32699)

OSM API: http://opengeofiction.net/api


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.gui.io.SaveLayersDialog$SaveAndProceedAction.<init>(SaveLayersDialog.java:383)
	at org.openstreetmap.josm.gui.io.SaveLayersDialog.<init>(SaveLayersDialog.java:71)
	at org.openstreetmap.josm.Main.saveUnsavedModifications(Main.java:934)
	at org.openstreetmap.josm.gui.dialogs.layer.DeleteLayerAction.actionPerformed(DeleteLayerAction.java:46)
	at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2022)
	at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2348)
	at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
	at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
	at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:252)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:289)
	at java.awt.Component.processMouseEvent(Component.java:6535)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6300)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4525)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by Don-vip

Summary: delete "cycle routes" layer caused unexpected exceptiondelete "cycle routes" layer caused NPE at SaveLayersDialog$SaveAndProceedAction

comment:2 Changed 3 years ago by ardisphere@…

After some troubleshooting, I believe this exception was being caused by the plugin called "plastic_laf". I removed the plugin and the problem ended.

comment:3 Changed 13 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #14016.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.