Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13574 closed defect (fixed)

Waypoint labelling "None" doesn't work

Reported by: anonymous Owned by: team
Priority: minor Milestone: 16.10
Component: Core Version: latest
Keywords: template_report, preferences, waypoint, labelling Cc:

Description

What steps will reproduce the problem?

  1. Go to Preferences, select "Expert mode"
  2. Go to Display Settings and GPS Points
  3. Select Waypoint labelling to "None" or "Custom" but leave TextField empty
  4. Save
  5. Go to Preferences, Display Settings and GPS Points

What is the expected result?

Waypoint Labelling is set to "None" or empty Custom

What happens instead?

Waypoint Labelling is reset to Default (Auto)

Please provide any additional information below. Attach a screenshot if possible.

I just have a short look at the code.
I located to ../preferences/display/GPXSettingsPanel.java:390
and ../layer/markerlayer/Marker.java:116

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-09-06 00:16:07 +0200 (Tue, 06 Sep 2016)
Build-Date:2016-09-05 22:21:00
Revision:10966
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10966 de) Windows 8.1 64-Bit
Memory Usage: 424 MB / 910 MB (284 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
+ turnrestrictions (32796)

Last errors/warnings:
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'
- W: Unable to get color from '' for color preference 'extrude.main.line'
- W: Unable to get color from '' for color preference 'improve.way.accuracy.helper.line'
- W: Unable to get color from '' for color preference 'make.parallel.helper.line'

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by simon04

Resolution: fixed
Status: newclosed

In 11039/josm:

fix #13574 - Waypoint labelling "None" doesn't work

Store space character since Preferences#put(java.lang.String, java.lang.String) ignores empty strings.

comment:2 Changed 3 years ago by simon04

Milestone: 16.09

comment:3 Changed 3 years ago by simon04

Milestone: 16.0916.10

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.