Modify

Opened 3 years ago

Closed 2 years ago

#13528 closed defect (duplicate)

StackOverflowError in Splinex plugin

Reported by: anonymous Owned by: anonymous
Priority: normal Milestone:
Component: Plugin splinex Version:
Keywords: template_report Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Draw some points with in Splinex plugin mode

What is the expected result?

What happens instead?

Josm crashes

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 it) Windows Vista 32-Bit
Memory Usage: 198 MB / 247 MB (57 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
+ FastDraw (32773)
+ Mapillary (32882)
+ PicLayer (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ contourmerge (1021)
+ dataimport (32699)
+ ejml (32680)
+ geotools (32813)
+ importvec (32699)
+ jts (32699)
+ log4j (32699)
+ opendata (32898)
+ photo_geotagging (32699)
+ reltoolbox (32796)
+ reverter (32796)
+ splinex (32796)
+ turnrestrictions (32796)
+ utilsplugin2 (32815)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountains&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryChangesetDialog$SubmitAction@17dfaa3
- E: java.lang.StackOverflowError


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.StackOverflowError
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:27)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)
...
	at org.openstreetmap.josm.plugins.Splinex.SplineHitTest.checkCurve(SplineHitTest.java:74)

Attachments (2)

splinex.png (76.1 KB) - added by GerdP 3 years ago.
log.zip (4.6 KB) - added by GerdP 3 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 3 years ago by Klumbumbus

Component: CorePlugin splinex
Owner: changed from team to Upliner

comment:2 Changed 3 years ago by Don-vip

Summary: Splinex plugin crashes JOSMStackOverflowError in Splinex plugin

comment:3 Changed 3 years ago by Don-vip

Description: modified (diff)
Owner: changed from Upliner to anonymous
Status: newneedinfo

I can't reproduce, can you please explain how did you get this error, with a screenshot if possible?

comment:4 Changed 3 years ago by GerdP

I am able to reproduce the problem:
1) Start JOSM
2) Ctrl+N for new layer
3) Make sure it shows 1000.0m resolution
4) Draw nodes like in the screenshot, the exact position doesn't seem to matter

Changed 3 years ago by GerdP

Attachment: splinex.png added

Changed 3 years ago by GerdP

Attachment: log.zip added

comment:5 Changed 3 years ago by GerdP

I've started JOSM with option --debug and reproduced the problem again, log.zip shows the stdout. I've replaced lots of repeated lines like below by a line "..."
FINE: checkCurve 1,001 425 1,001 425 1,001 425 1,001 425
Sep 12, 2016 11:50:00 AM org.openstreetmap.josm.Main debug
FINE: checkCurve 1,001 425 1,001 425 1,001 425 1,001 425
Sep 12, 2016 11:50:00 AM org.openstreetmap.josm.Main debug

Hope this helps.

comment:6 Changed 2 years ago by Upliner

Resolution: duplicate
Status: needinfoclosed

Closed as duplicate of #14416.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain anonymous.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.