Modify

Opened 6 years ago

Closed 2 months ago

#13484 closed enhancement (duplicate)

Use fix value as a choice for track/point drawing

Reported by: StephaneP Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: rtk; gpx; gnss; gps; track coloring Cc:

Description

Hi!

I'm starting to use Real Time Kinematic with my gnss receivers, with RTKLIB, and I think that i'm not the only one in the osm world to experiment this.
A very cool feature for josm would be to directly read the .pos files created with RTKLib, but I think it's too much work for a very user's group.

But since this summer, RTKLib can export the .pos file to .gpx file. In the gpx file, each point got a fix value : "fix","float","sbas","dgps","single","ppp"
fix or ppp is better than float, which is better than dgps > sbas > single

"single" is equal to the "3d" value written in the gpx specifications http://www.topografix.com/gpx_manual.asp#fix.

Would it be possible to have an option to color the trace from the fix value like in RTKPLOT ?

Attachments (1)

couleur rtkplot.JPG (33.8 KB) - added by StephaneP 6 years ago.
Rendering in RTKPLOT

Download all attachments as: .zip

Change History (12)

Changed 6 years ago by StephaneP

Attachment: couleur rtkplot.JPG added

Rendering in RTKPLOT

comment:1 Changed 6 years ago by StephaneP

BTW : I've requested the RTKLIB dev to add the dop value in the gpx :
https://github.com/tomojitakasu/RTKLIB/issues/214

comment:2 Changed 3 years ago by Don-vip

is this ticket still needed now that JOSM support RTKlib .pos files?

comment:3 Changed 3 years ago by Don-vip

Owner: changed from team to StephaneP
Status: newneedinfo

comment:4 Changed 3 years ago by StephaneP

It will be useful when I will find some time to write a private extension for gpx files.

comment:5 Changed 3 years ago by stoecker

I also added a style to colorize data based on fix status: Styles/ColourGPSData. It needs a conversion of NMEA (GPX?) to a data layer first.

I wonder if GPX layers should support MapCSS as well, so they can be styled directly instead of implementing all variants in JOSM core.

comment:6 Changed 3 years ago by Don-vip

It should be feasible for simple cases, but more complex ones like heatmap I'm not sure it would be possible in MapCSS.

comment:7 in reply to:  6 Changed 3 years ago by stoecker

Replying to Don-vip:

It should be feasible for simple cases, but more complex ones like heatmap I'm not sure it would be possible in MapCSS.

I wouldn't drop the existing ones, rather add styling additional and maybe allow to access the existing coloring features via MapCSS.

comment:8 Changed 3 years ago by Don-vip

Owner: changed from StephaneP to team
Status: needinfonew

comment:9 Changed 3 years ago by Bjoeni

@stoecker I think your style needs to be updated to match the gpx: prefix since r15419

Last edited 3 years ago by Bjoeni (previous) (diff)

comment:10 Changed 2 months ago by skyper

See also #20600. #20601 and #21810

comment:11 Changed 2 months ago by Bjoeni

Resolution: duplicate
Status: newclosed

Closed as duplicate of #20600.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.