Modify

Opened 2 years ago

Closed 2 years ago

#13471 closed defect (duplicate)

erreur josm en quittant ou en supprimant un calque

Reported by: jeanrobert.mavet@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. image layer in trash
  2. exit
  3. sometimes in upload

Error message and freeze

Upload is OK

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 fr) Windows 10 64-Bit
Memory Usage: 1377 MB / 6222 MB (398 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
+ AddrInterpolation (32699)
+ ImageWayPoint (32699)
+ alignways (32796)
+ apache-commons (32699)
+ buildings_tools (32796)
+ cadastre-fr (32796)
+ colorscheme (32699)
+ dataimport (32699)
+ ejml (32680)
+ fieldpapers (v0.4.0)
+ geotools (32699)
+ jts (32699)
+ merge-overlap (32699)
+ photo_geotagging (32699)
+ print (32699)
+ tageditor (32796)
+ utilsplugin2 (32796)

Last errors/warnings:
- E: Impossible de trouver l'image "Flag, Blue"
- E: Impossible de trouver l'image "Flag, Blue"
- E: Impossible de trouver l'image "Flag, Blue"
- E: Impossible de trouver l'image "Flag, Blue"
- E: Impossible de trouver l'image "Flag, Blue"
- E: Impossible de trouver l'image "Flag, Blue"
- E: Impossible de trouver l'image "Flag, Blue"
- E: Impossible de trouver l'image "Flag, Blue"
- E: Impossible de trouver l'image "Flag, Blue"
- E: java.lang.IllegalArgumentException: Listener was not registered before: LayerChangeAdapter [ToggleDialogAction [Image WayPoint]]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.IllegalArgumentException: Listener was not registered before: LayerChangeAdapter [ToggleDialogAction [Image WayPoint]]
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:364)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:352)
	at org.openstreetmap.josm.actions.JosmAction.destroy(JosmAction.java:220)
	at org.openstreetmap.josm.gui.IconToggleButton.destroy(IconToggleButton.java:72)
	at org.openstreetmap.josm.gui.MapFrame.destroy(MapFrame.java:338)
	at org.openstreetmap.josm.gui.MainPanel.updateContent(MainPanel.java:58)
	at org.openstreetmap.josm.gui.MainPanel$1.afterLastLayerRemoved(MainPanel.java:162)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.realRemoveSingleLayer(MainLayerManager.java:286)
	at org.openstreetmap.josm.gui.layer.LayerManager.realRemoveLayer(LayerManager.java:219)
	at org.openstreetmap.josm.gui.layer.LayerManager.lambda$removeLayer$1(LayerManager.java:205)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:138)
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayer(LayerManager.java:205)
	at org.openstreetmap.josm.gui.layer.LayerManager.resetState(LayerManager.java:423)
	at org.openstreetmap.josm.gui.layer.MainLayerManager.resetState(MainLayerManager.java:392)
	at org.openstreetmap.josm.Main.shutdown(Main.java:1141)
	at org.openstreetmap.josm.gui.MainApplication.shutdown(MainApplication.java:116)
	at org.openstreetmap.josm.Main.exitJosm(Main.java:1122)
	at org.openstreetmap.josm.gui.MainFrame$1.windowClosing(MainFrame.java:94)
	at java.awt.AWTEventMulticaster.windowClosing(Unknown Source)
	at java.awt.Window.processWindowEvent(Unknown Source)
	at javax.swing.JFrame.processWindowEvent(Unknown Source)
	at java.awt.Window.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #13450.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.