Modify

Opened 5 years ago

Closed 3 years ago

#13463 closed defect (duplicate)

Undo selection works only if nothing is selected

Reported by: GerdP Owned by: team
Priority: normal Milestone:
Component: Plugin utilsplugin2 Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Download an area
  2. Select some objects (e.g. with lasso)
  3. Select a single different object
  4. Press Shift+Crtl+Z to "Undo selection"

What is the expected result?

All the objects selected with step 2 should be selected again

What happens instead?

nothing (object selected in step 3 remains selected)

Please provide any additional information below. Attach a screenshot if possible.

If I change step 3 to "Press Escape to unselect all nodes" I get the expected result with step 4.
Maybe this is intended, but I would expect that with "Undo Unselect".

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 en) Windows 10 64-Bit
Memory Usage: 618 MB / 1753 MB (324 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-XX:StartFlightRecording=name=MyRecording2,settings=d:\dbg\gerd.jfc, -XX:FlightRecorderOptions=defaultrecording=true,dumponexit=true,dumponexitpath=e:\ld\perf_20160826_110848.jfr]
Dataset consistency test: No problems found

Plugins:
+ apache-commons (32699)
+ buildings_tools (32796)
+ ejml (32680)
+ geotools (32813)
+ jts (32699)
+ o5m (32857)
+ opendata (32811)
+ pbf (32865)
+ poly (32699)
+ reverter (32796)
+ utilsplugin2 (32815)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by bastiK

Component: CorePlugin utilsplugin2

comment:2 Changed 3 years ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17082.
Sorry, I forgot that I created this ticket before.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.