Modify

Opened 5 years ago

Closed 5 years ago

#13461 closed defect (fixed)

InterruptedException when adding mapillary layer

Reported by: Polyglot Owned by: nokutu
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. I installed josm-latest, then went to work on the city of Leuven
  2. Mapillary is standard on when launching JOSM. I don't like that, I only want it to be active when I happen to need horizontal imagery.
  3. There are thousands of pictures for Leuven, which makes everything very slow to work with.

I'm also missing the possibility to have the buttons on top, so I can move the mapillary window out of the way, but still go to next/previous. The possibility to do that got lost in some update.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-25 23:21:10 +0200 (Thu, 25 Aug 2016)
Build-Date:2016-08-26 01:33:11
Revision:10899
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10899 en) Windows 7 64-Bit
Memory Usage: 1286 MB / 2889 MB (189 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Dataset consistency test:
[WARN - NO NODES] Way {Way id=292056897 version=3 VT nodes=[{Node id=2955706680 version=1 V lat=50.8822957,lon=4.6971856}]} has only one node


Plugins:
+ CustomizePublicTransportStop (0.3)
+ Mapillary (32796)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ RoadSigns (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32796)
+ geochat (32796)
+ livegps (32699)
+ pt_assistant (32874)
+ reverter (32796)
+ scripting (30730)
+ surveyor (32796)
+ tag2link (32699)
+ terracer (32699)
+ todo (29154)
+ turnrestrictions (32796)
+ undelete (32699)
+ utilsplugin2 (32815)
+ wikipedia (32829)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BENELUX&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NumberedCycleNodeNetworks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NumberedWalkingNodeNetworks&zip=1

Last errors/warnings:
- W: Invalid jar file ''<josm.pref>\plugins\pt_assistant.jar.new'' (exists: false, canRead: false)
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryChangesetDialog$SubmitAction@681eeca6
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$SelectAction@4895addd
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$AddAction@7de13b1a
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$PassAction@44b722e3
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.todo.TodoDialog$MarkAction@1beb85a1
- E: Mapillary download interrupted (probably because of closing the layer).


=== REPORTED CRASH DATA ===
BugReport#intercept:
 - task: org.openstreetmap.josm.gui.layer.LayerManager$$Lambda$136/1248498824@20b5e197

BugReport#intercept:
No data collected.

Warning issued by: ReportedException#warn

=== STACK TRACE ===
Thread: pool-10-thread-2 (375)
java.lang.InterruptedException
	at java.lang.Object.wait(Native Method)
	at java.lang.Object.wait(Unknown Source)
	at java.awt.EventQueue.invokeAndWait(Unknown Source)
	at java.awt.EventQueue.invokeAndWait(Unknown Source)
	at javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
	at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWaitWithException(GuiHelper.java:141)
	at org.openstreetmap.josm.gui.layer.LayerManager.addLayer(LayerManager.java:180)
	at org.openstreetmap.josm.plugins.mapillary.MapillaryLayer.init(MapillaryLayer.java:112)
	at org.openstreetmap.josm.plugins.mapillary.MapillaryLayer.getInstance(MapillaryLayer.java:182)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySequenceDownloadThread.run(MapillarySequenceDownloadThread.java:100)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by Don-vip

Summary: Mapillary plugin crashesInterruptedException when adding mapillary layer

comment:2 Changed 5 years ago by nokutu

Resolution: fixed
Status: newclosed

I found the issue and fixed it. The layer should open when launching any more.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nokutu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.