Modify

Opened 5 years ago

Closed 5 years ago

#13459 closed defect (duplicate)

NullPointerException in Mapillary plugin while browsing pictures

Reported by: Polyglot Owned by: nokutu
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. I was simply browsing pictures for a few minutes.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-09 00:25:24 +0200 (Tue, 09 Aug 2016)
Build-Date:2016-08-09 01:35:26
Revision:10770
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10770 en) Windows 7 64-Bit
Memory Usage: 1514 MB / 2889 MB (592 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
+ CustomizePublicTransportStop (0.3)
+ Mapillary (32796)
+ OpeningHoursEditor (32699)
+ PicLayer (32796)
+ RoadSigns (32796)
+ apache-commons (32699)
+ apache-http (32699)
+ buildings_tools (32796)
+ geochat (32796)
+ livegps (32699)
+ pt_assistant (32855)
+ reverter (32796)
+ scripting (30730)
+ surveyor (32796)
+ tag2link (32699)
+ terracer (32699)
+ todo (29154)
+ turnrestrictions (32796)
+ undelete (32699)
+ utilsplugin2 (32815)
+ wikipedia (32829)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/BENELUX&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NumberedCycleNodeNetworks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NumberedWalkingNodeNetworks&zip=1

Last errors/warnings:
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Could not connect to the OSM server. Please check your internet connection.. Cause: java.net.UnknownHostException: api.openstreetmap.org
- E: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NullPointerException
	at org.glassfish.json.JsonObjectBuilderImpl$JsonObjectImpl.getString(JsonObjectBuilderImpl.java:199)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillaryTrafficSignDownloadThread.run(MapillaryTrafficSignDownloadThread.java:71)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by Don-vip

Summary: Mapillary plugin had an issue while browsing picturesNullPointerException in Mapillary plugin while browsing pictures

comment:2 Changed 5 years ago by nokutu

Did this happen any more time or was just a one time error?

comment:3 Changed 5 years ago by Polyglot

one time, I think

comment:4 Changed 5 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12861.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain nokutu.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.