Modify

Opened 6 years ago

Closed 6 years ago

#13455 closed defect (worksforme)

Building Plugin Fails.

Reported by: anonymous Owned by: Upliner
Priority: normal Milestone:
Component: Plugin buildings_tools Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 en_AU) Windows 7 64-Bit
Memory Usage: 270 MB / 455 MB (142 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
+ DirectDownload (30413)
+ DirectUpload (30413)
+ PicLayer (30413)
+ buildings_tools (32639)
+ geotools (30349)
+ jna (31126)
+ jts (30277)
+ log4j (30197)
+ photo_geotagging (30413)
+ photoadjust (30413)
+ print (31329)
+ turnrestrictions (30413)
+ utilsplugin2 (30413)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Mountainbike&preset
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/MountainbikeTrails&preset

Map paint styles:
- C:\Program Files (x86)\JOSM\MapCss\MTB_IMBA.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&style
- https://josm.openstreetmap.de/josmfile?page=Styles/MTB&zip=1
- C:\Program Files (x86)\CreateIMG 08\OSM-Data\Munda Biddi\MTB Route Staus.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: Plugin seems to be adding listener during mapFrameInitialized(): PhotoAdjustPlugin#mapFrameInitialized. Layer listeners should be set on plugin load.
- W: Plugin seems to be adding listener during mapFrameInitialized(): PhotoAdjustMapMode#<init>. Layer listeners should be set on plugin load.
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog$NewAction@308baa8
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog$EditAction@32e11ee6
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.turnrestrictions.list.TurnRestrictionsListDialog$DeleteAction@c513b15
- E: java.lang.NoSuchFieldError: isUsablePredicate
- E: java.lang.NoSuchFieldError: isUsablePredicate
- E: java.lang.NoSuchFieldError: isUsablePredicate


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NoSuchFieldError: isUsablePredicate
	at buildings_tools.DrawBuildingAction.updCursor(DrawBuildingAction.java:364)
	at buildings_tools.DrawBuildingAction.mouseMoved(DrawBuildingAction.java:381)
	at java.awt.AWTEventMulticaster.mouseMoved(Unknown Source)
	at java.awt.Component.processMouseMotionEvent(Unknown Source)
	at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by Don-vip

Component: CorePlugin building_tools
Owner: changed from team to Upliner

comment:2 Changed 6 years ago by Don-vip

Resolution: worksforme
Status: newclosed

You're not using the latest version of the plugin (32796), please update your plugins.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Upliner.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.