Modify

Opened 3 years ago

Closed 2 years ago

#13409 closed defect (duplicate)

Fast draw plugin NPE at FastDrawingMode.mouseMoved

Reported by: anonymous Owned by: akks
Priority: normal Milestone:
Component: Plugin FastDraw Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 en) Windows 10 64-Bit
Memory Usage: 478 MB / 910 MB (174 MB allocated, but free)
Java version: 1.8.0_65-b17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
+ BuildingGeneralization (1010)
+ Create_grid_of_ways (32699)
+ DirectDownload (32699)
+ FastDraw (32773)
+ FixAddresses (32796)
+ HouseNumberTaggingTool (32699)
+ OSMRecPlugin (32796)
+ PicLayer (32796)
+ Tracer-testing (1457538387)
+ Tracer2 (32788)
+ alignways (32796)
+ apache-commons (32699)
+ areaselector (282)
+ buildings_tools (32796)
+ continuosDownload (53)
+ contourmerge (1021)
+ dataimport (32699)
+ ejml (32680)
+ ext_tools (32796)
+ geotools (32813)
+ imagery_offset_db (32796)
+ imageryadjust (32699)
+ importvec (32699)
+ jts (32699)
+ log4j (32699)
+ measurement (32732)
+ merge-overlap (32699)
+ osmarender (32699)
+ pdfimport (32796)
+ photoadjust (32796)
+ reltoolbox (32796)
+ reverter (32796)
+ tageditor (32796)
+ tagging-preset-tester (32699)
+ terracer (32699)
+ tofix (267)
+ turnlanes (32796)
+ turnrestrictions (32629)
+ utilsplugin2 (32815)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Traffic_signs&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: URL does not contain zoom/latitude/longitude
- W: URL does not contain zoom/latitude/longitude
- W: URL does not contain zoom/latitude/longitude
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException
- E: java.lang.NullPointerException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (19) of main
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.fastdraw.FastDrawingMode.mouseMoved(FastDrawingMode.java:392)
	at java.awt.AWTEventMulticaster.mouseMoved(Unknown Source)
	at java.awt.Component.processMouseMotionEvent(Unknown Source)
	at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by Don-vip

Component: CorePlugin
Summary: Fast draw plug-in created this errorFast draw plug-in NPE

comment:2 Changed 3 years ago by Klumbumbus

Component: PluginPlugin FastDraw
Owner: changed from team to akks

comment:3 Changed 3 years ago by Klumbumbus

Ticket #15069 has been marked as a duplicate of this ticket.

comment:4 Changed 3 years ago by Klumbumbus

Summary: Fast draw plug-in NPEFast draw plugin NPE at FastDrawingMode.mouseMoved

comment:5 Changed 2 years ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #15482.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain akks.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.