Modify

Opened 6 years ago

Closed 6 years ago

#13338 closed defect (fixed)

SSLException in Mapillary plugin on activation of large area

Reported by: lists@… Owned by: Don-vip
Priority: critical Milestone:
Component: Plugin mapillary Version: tested
Keywords: template_report Cc: lists@…, Hobgoblin

Description

What steps will reproduce the problem?

  1. Download a larger area, i.e. a whole town
  2. Activate Mapillary layer
  3. Wait

What is the expected result?

Mapillary start downloading data in the area

What happens instead?

Mapillary failed with message about area being too big

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 en) Mac OS X 10.11.6
Memory Usage: 497 MB / 910 MB (173 MB allocated, but free)
Java version: 1.8.0_101-b13, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
+ FixAddresses (32796)
+ Mapillary (32796)
+ OpeningHoursEditor (32699)
+ SeaChart (32699)
+ SeaMapEditor (32767)
+ apache-commons (32699)
+ apache-http (32699)
+ continuosDownload (53)
+ ejml (32680)
+ geochat (32796)
+ geotools (32699)
+ jts (32699)
+ merge-overlap (32699)
+ opendata (32796)
+ reverter (32796)
+ rex (1928)
+ turnlanes (32796)
+ turnrestrictions (32796)
+ undelete (32699)
+ utilsplugin2 (32796)
+ waydownloader (32699)

Tagging presets:
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Presets_Sport.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/OpenSeaMap_bridge&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Leaftype&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://github.com/simonpoole/beautified-JOSM-preset/raw/master/gen/vespucci_zip.zip
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1

Map paint styles:
+ ${HOME}/Documents/workspace/mapnik-brasil/base.mapcss
- ${HOME}/Documents/workspace/JOSM-ONC/INT1_MapCSS.mapcss
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/BNIWR_MapCSS.mapcss
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/CEVNI_MapCSS.mapcss
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT1_Seamark.mapcss
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/PPWBC_MapCSS.mapcss

Validator rules:
+ https://raw.githubusercontent.com/OSMBrasil/validador-josm/master/Rules_Brazilian-Specific.validator.mapcss
+ https://raw.githubusercontent.com/OpenSeaMap/josm/master/Seamark.validator.mapcss
+ https://raw.githubusercontent.com/stefan-a-bauer/josm-validators/master/mtb.validator.mapcss

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- E: javax.json.JsonException: I/O error while parsing JSON. Cause: javax.net.ssl.SSLException: SSL peer shut down incorrectly


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
javax.json.JsonException: I/O error while parsing JSON
	at org.glassfish.json.JsonTokenizer.read(JsonTokenizer.java:444)
	at org.glassfish.json.JsonTokenizer.readNumberChar(JsonTokenizer.java:243)
	at org.glassfish.json.JsonTokenizer.readNumber(JsonTokenizer.java:272)
	at org.glassfish.json.JsonTokenizer.nextToken(JsonTokenizer.java:410)
	at org.glassfish.json.JsonParserImpl$ArrayContext.getNextEvent(JsonParserImpl.java:303)
	at org.glassfish.json.JsonParserImpl$StateIterator.next(JsonParserImpl.java:172)
	at org.glassfish.json.JsonParserImpl.next(JsonParserImpl.java:149)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:136)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:139)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:180)
	at org.glassfish.json.JsonReaderImpl.readArray(JsonReaderImpl.java:143)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:180)
	at org.glassfish.json.JsonReaderImpl.readObject(JsonReaderImpl.java:103)
	at org.openstreetmap.josm.plugins.mapillary.io.download.MapillarySequenceDownloadThread.run(MapillarySequenceDownloadThread.java:59)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)
Caused by: javax.net.ssl.SSLException: SSL peer shut down incorrectly
	at sun.security.ssl.InputRecord.readV3Record(InputRecord.java:596)
	at sun.security.ssl.InputRecord.read(InputRecord.java:532)
	at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:973)
	at sun.security.ssl.SSLSocketImpl.readDataRecord(SSLSocketImpl.java:930)
	at sun.security.ssl.AppInputStream.read(AppInputStream.java:105)
	at java.io.BufferedInputStream.fill(BufferedInputStream.java:246)
	at java.io.BufferedInputStream.read1(BufferedInputStream.java:286)
	at java.io.BufferedInputStream.read(BufferedInputStream.java:345)
	at sun.net.www.http.ChunkedInputStream.fastRead(ChunkedInputStream.java:244)
	at sun.net.www.http.ChunkedInputStream.read(ChunkedInputStream.java:689)
	at java.io.FilterInputStream.read(FilterInputStream.java:133)
	at sun.net.www.protocol.http.HttpURLConnection$HttpInputStream.read(HttpURLConnection.java:3336)
	at sun.nio.cs.StreamDecoder.readBytes(StreamDecoder.java:284)
	at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:326)
	at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:178)
	at java.io.InputStreamReader.read(InputStreamReader.java:184)
	at java.io.BufferedReader.fill(BufferedReader.java:161)
	at java.io.BufferedReader.read1(BufferedReader.java:212)
	at java.io.BufferedReader.read(BufferedReader.java:286)
	at org.glassfish.json.JsonTokenizer.fillBuf(JsonTokenizer.java:473)
	at org.glassfish.json.JsonTokenizer.read(JsonTokenizer.java:434)
	... 16 more

Attachments (0)

Change History (14)

comment:1 Changed 6 years ago by Don-vip

Summary: Mapillary plugin faulting on activation for large areaSSLException in Mapillary plugin on activation of large area

comment:2 Changed 6 years ago by nokutu

Owner: changed from nokutu to lists@…
Status: newneedinfo

What download mode are you using? And could you try with latest version?

Thanks

comment:3 Changed 6 years ago by stoecker

Ticket #13490 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by Don-vip

Ticket #13498 has been marked as a duplicate of this ticket.

comment:5 Changed 6 years ago by Aun Johnsen <lists@…>

I generally use continuousDownload plugin, but this problem happens also with remote control (download requested from osm.org) and manual downloads, even with continuousDownload disabled. It also happens after moving the map, within an already downloaded area, so it might be some event captured by the plugin.

Doesn't seem to be necessary to have mapillary data within the area, I get the error independent of the amount of mapillary in the area.

comment:6 Changed 6 years ago by Klumbumbus

Ticket #13686 has been marked as a duplicate of this ticket.

comment:7 Changed 6 years ago by Klumbumbus

Cc: Hobgoblin added

comment:8 Changed 6 years ago by anonymous

Ticket #13782 has been marked as a duplicate of this ticket.

comment:9 Changed 6 years ago by Klumbumbus

Ticket #13997 has been marked as a duplicate of this ticket.

comment:10 Changed 6 years ago by anonymous

Ticket #14308 has been marked as a duplicate of this ticket.

comment:11 Changed 6 years ago by Don-vip

Priority: normalcritical

comment:13 Changed 6 years ago by Don-vip

Owner: changed from lists@… to Don-vip
Status: needinfoassigned

PR merged

comment:14 Changed 6 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.