Modify

Opened 4 years ago

Closed 4 years ago

#13324 closed defect (duplicate)

A plugin handling shapes is wrong ?

Reported by: hendrikklaas Owned by: team
Priority: normal Milestone:
Component: Plugin shapetools Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Installing JOSM Launch josm.jnlp (version 10786)
  2. After installing and refreshing of the Plugin its still a fault.
  3. The programm crashed.

What is the expected result?

None a crash

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-08-11 21:54:24 +0200 (Thu, 11 Aug 2016)
Build-Date:2016-08-11 22:36:05
Revision:10786
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10786 nl) Windows 10 64-Bit
Memory Usage: 202 MB / 989 MB (62 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
+ ShapeTools (1010)
+ dataimport (32484)
+ ejml (32639)
+ geotools (32584)
+ jts (32539)
+ poly (32584)
+ reverter (32584)
+ undelete (32584)
+ utilsplugin2 (32725)
+ waydownloader (32584)

Validator rules:
+ http://www.openrailwaymap.org/validator/de-openrailwaymap.validator.mapcss
+ http://www.openrailwaymap.org/validator/openrailwaymap.validator.mapcss

Last errors/warnings:
- E: java.net.SocketTimeoutException: Read timed out
- E: org.openstreetmap.josm.io.OsmTransferException: Kon geen verbinding maken met de server van OSM. Controleer uw verbinding met internet.. Oorzaak: java.net.SocketTimeoutException: Read timed out
- E: Invoer/uitvoer-exceptie - <html>Uploaden van gegevens naar of downloaden van gegevens vanaf<br>'https://api.openstreetmap.org/api/0.6/map?bbox=3.4871292,51.3872091,3.5540771,51.4128586' mislukt<br>wegens een probleem met het overdragen van gegevens.<br>Details (niet vertaald): Read timed out</html>
- W: java.net.SocketException: Socket Closed
- E: java.net.SocketException: Socket Closed
- W: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled. Oorzaak: org.openstreetmap.josm.io.OsmTransferException: Kon geen verbinding maken met de server van OSM. Controleer uw verbinding met internet.. Oorzaak: java.net.SocketException: Socket Closed
- W: java.net.SocketException: Socket Closed
- E: java.net.SocketException: Socket Closed
- W: org.openstreetmap.josm.io.OsmTransferCanceledException: Operation canceled. Oorzaak: org.openstreetmap.josm.io.OsmTransferException: Kon geen verbinding maken met de server van OSM. Controleer uw verbinding met internet.. Oorzaak: java.net.SocketException: Socket Closed
- E: java.lang.NoSuchFieldError: isUsablePredicate


=== REPORTED CRASH DATA ===
BugReportExceptionHandler$BugReporterThread#askForBugReport:
No data collected.

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.NoSuchFieldError: isUsablePredicate
	at org.openstreetmap.josm.plugins.shapetools.ShapeMode.mouseClicked(ShapeMode.java:42)
	at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
	at java.awt.AWTEventMulticaster.mouseClicked(Unknown Source)
	at java.awt.Component.processMouseEvent(Unknown Source)
	at javax.swing.JComponent.processMouseEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by anonymous

? whats happening here ?
Im not a programmer and just a humble mapper.

comment:2 Changed 4 years ago by simon04

Component: CorePlugin shapetools
Resolution: duplicate
Status: newclosed

Closed as duplicate of #13285.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.