Modify

Opened 4 years ago

Closed 4 years ago

#13296 closed defect (fixed)

[Patch] Search for incomplete object seems not to work

Reported by: GerdP Owned by: team
Priority: minor Milestone: 16.08
Component: Core Version:
Keywords: template_report search Cc: stoecker

Description

What steps will reproduce the problem?

  1. Load the attached file which contains incomplete relations
  2. Open the search dialog (Ctrl+F), select options replace selection and standard
  3. Search for incomplete

What is the expected result?

the incomplete relations and ways

What happens instead?

a popup shows "No match found for 'incomplete' ", see screen shot

Please provide any additional information below. Attach a screenshot if possible.

When I enable the option "all objects" in the search dialog the search result
contains the ways but still not the relations.
No idea why the option "all objects" exists, it is not explained in the help page,
but I would always expect that JOSM searches all objects.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-11 23:04:49 +0200 (Mon, 11 Jul 2016)
Build-Date:2016-07-12 01:31:48
Revision:10526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10526 en) Windows 10 64-Bit
Memory Usage: 5290 MB / 5461 MB (4528 MB allocated, but free)
Java version: 1.8.0_102-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-XX:StartFlightRecording=name=MyRecording2,settings=d:\dbg\gerd.jfc, -XX:FlightRecorderOptions=defaultrecording=true,dumponexit=true,dumponexitpath=e:\ld\perf_20160809_100714.jfr, -Dsun.java2d.opengl=true]
Dataset consistency test: No problems found

Plugins:
- apache-commons (32584)
- buildings_tools (32639)
- ejml (32639)
- geotools (32584)
- jts (32539)
- o5m (UNKNOWN)
- opendata (32584)
- pbf (32584)
- poly (32584)
- reverter (32584)
- utilsplugin2 (32584)

Last errors/warnings:
- W: Unable to delete file <josm.cache>\tiles\TMS.key
- W: Unable to delete file <josm.cache>\tiles\TMS.data
- W: Unable to delete file <josm.cache>\tiles\TMS_BLOCK.key
- W: Unable to delete file <josm.cache>\tiles\TMS_BLOCK.data
- W: Unable to delete file <josm.cache>\tiles\TMS_INDEX.key
- W: Unable to delete file <josm.cache>\tiles\TMS_INDEX.data
- W: Unable to delete file <josm.cache>\tiles\TMS_INDEX_v2.key
- W: Unable to delete file <josm.cache>\tiles\TMS_INDEX_v2.data

Attachments (3)

incomplete.zip (265.7 KB) - added by GerdP 4 years ago.
incomplete.png (772.9 KB) - added by GerdP 4 years ago.
13296.patch (660 bytes) - added by simon04 4 years ago.

Download all attachments as: .zip

Change History (9)

Changed 4 years ago by GerdP

Attachment: incomplete.zip added

Changed 4 years ago by GerdP

Attachment: incomplete.png added

comment:1 Changed 4 years ago by GerdP

Maybe related to this:
I wonder why JOSM stores incomplete ways or nodes in a QuadBuckets structure. These elements are never returned
when QuadBuckets.search(BBox searchBbox) is used, and that seems to be the only way how this structure
is used. All incomplete ways are stored in the root of the quad tree.
The effect of this is that each call of Dataset.searchNodes(BBox bbox) or Dataset.searchWays(BBox bbox) is slowed down
as all incomplete members of relations are searched sequentially.

Changed 4 years ago by simon04

Attachment: 13296.patch added

comment:2 Changed 4 years ago by simon04

Cc: stoecker added
Milestone: 16.08
Summary: Search for incomplete object seems not to work[Patch] Search for incomplete object seems not to work

"All objects" has been introduced in r3317. Maybe Dirk still remembers the usecase. :)

The relations in your example contain incomplete members, but are themselves not considered incomplete. Thus attachment:13296.patch​ should address this issue.

comment:3 Changed 4 years ago by GerdP

OK, I think I understand. According to the tooltip the "all objects" switch
will include incomplete and deleted objects. Maybe it would be better to add
"deleted" to the list of search attributes (like new, modified etc) and remove
the "all objects" checkbox?

comment:4 in reply to:  2 Changed 4 years ago by stoecker

Replying to simon04:

"All objects" has been introduced in r3317. Maybe Dirk still remembers the usecase. :)

You must have a possibility to access all contained elements even when only few users will do that. There are (or have been) situations when access to all members was required for (non-standard) workflows. Don't ask me for exact details today ... Dropping elements comes to my mind ...

Replacing the checkbox with other searches doesn't sound good to me, as it then is a guesswork what searches you need to get complete dataset.

comment:5 Changed 4 years ago by GerdP

Would it be possible to warn the user when he searches for incomplete without enabling the "all objects" checkbox?

comment:6 Changed 4 years ago by simon04

Resolution: fixed
Status: newclosed

In 10792/josm:

fix #13296 - Fix search for incomplete relations

Note that "all objects" has to be enabled in the search dialog.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.