Modify

Opened 4 years ago

Closed 4 years ago

#13272 closed defect (fixed)

Loading problem

Reported by: saliousoft Owned by: team
Priority: normal Milestone: 16.07
Component: Core Version:
Keywords: Cc:

Description

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-11 23:04:49 +0200 (Mon, 11 Jul 2016)
Build-Date:2016-07-12 01:31:48
Revision:10526
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10526 fr) Linux Ubuntu 14.04.4 LTS
Memory Usage: 315 MB / 747 MB (224 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-0ubuntu4~14.04-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]

Plugins:
- DirectDownload
- DirectUpload
- HouseNumberTaggingTool
- ImageWayPoint
- Mapillary
- apache-commons
- apache-http
- buildings_tools
- ejml
- fieldpapers
- geotools
- jts
- opendata
- photo_geotagging
- undelete
- utilsplugin2

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
- https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/Presets_Traffic_signs.zip

Last errors/warnings:
- W:  Emergency: Could not get presets icon presets/service/firebrigade.svg
- E: Impossible de trouver l'image "presets/sport/soccer.svg"
- W:  Sports: Could not get presets icon presets/sport/soccer.svg
- E: Impossible de trouver l'image "presets/sightseeing/attraction.svg"
- W:  Tourism: Could not get presets icon presets/sightseeing/attraction.svg
- E: Impossible de trouver l'image "presets/leisure/equestrian.png"
- W:  Trail Riding Station: Could not get presets icon presets/leisure/equestrian.png
- E: Impossible de trouver l'image "presets/landmark/works.svg"
- W:  Man Made: Could not get presets icon presets/landmark/works.svg
- E: java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: MALFORMED. Cause : java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: MALFORMED. Cause : java.lang.IllegalArgumentException: MALFORMED

java.lang.RuntimeException: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: MALFORMED
	at org.openstreetmap.josm.Main.initialize(Main.java:695)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:469)
Caused by: java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException: MALFORMED
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at org.openstreetmap.josm.Main.initialize(Main.java:691)
	... 1 more
Caused by: java.lang.IllegalArgumentException: MALFORMED
	at java.util.zip.ZipCoder.toString(ZipCoder.java:58)
	at java.util.zip.ZipFile.getZipEntry(ZipFile.java:566)
	at java.util.zip.ZipFile.access$900(ZipFile.java:60)
	at java.util.zip.ZipFile$ZipEntryIterator.next(ZipFile.java:524)
	at java.util.zip.ZipFile$ZipEntryIterator.nextElement(ZipFile.java:499)
	at java.util.zip.ZipFile$ZipEntryIterator.nextElement(ZipFile.java:480)
	at org.openstreetmap.josm.io.CachedFile.findZipEntryImpl(CachedFile.java:339)
	at org.openstreetmap.josm.io.CachedFile.findZipEntryInputStream(CachedFile.java:319)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPresetReader.readAll(TaggingPresetReader.java:328)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPresetReader.readAll(TaggingPresetReader.java:361)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPresetReader.readFromPreferences(TaggingPresetReader.java:397)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPresets.readFromPreferences(TaggingPresets.java:41)
	at org.openstreetmap.josm.gui.tagging.presets.TaggingPresets.initialize(TaggingPresets.java:48)
	at org.openstreetmap.josm.Main$6.initialize(Main.java:667)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:780)
	at org.openstreetmap.josm.Main$InitializationTask.call(Main.java:764)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by Klumbumbus

Ticket #13274 has been marked as a duplicate of this ticket.

comment:2 Changed 4 years ago by Klumbumbus

Ticket #13273 has been marked as a duplicate of this ticket.

comment:3 Changed 4 years ago by Don-vip

Milestone: 16.07

comment:4 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10732/josm:

fix #13272 - add robustness against malformed zip files

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.