Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13208 closed defect (fixed)

[Patch] Use real string for Concatenation

Reported by: michael2402 Owned by: Don-vip
Priority: normal Milestone: 16.07
Component: Core Version:
Keywords: gsoc-core regression Cc: Don-vip, bastiK, stoecker

Description (last modified by michael2402)

There were too many notes on that layer because int + char is a normal addition.

Caused by [8846]

@Don-vip

is there a special reason you are replacing one character strings with single character values? I found 445 more potential issues like this by searching for '.'\s*\+|\+\s*'.'

Attachments (1)

patch-fix-char-concat.patch (572 bytes) - added by michael2402 3 years ago.

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by michael2402

Attachment: patch-fix-char-concat.patch added

comment:1 Changed 3 years ago by michael2402

Summary: [Patch] Use real string for Concatination[Patch] Use real string for Concatenation

comment:2 Changed 3 years ago by michael2402

Description: modified (diff)
Keywords: regression added
Owner: changed from team to Don-vip

comment:3 Changed 3 years ago by Don-vip

This is a minor performance improvement, but I should have been more careful/add more unit tests. There was several other regressions I fixed since this commit.

comment:4 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10640/josm:

fix #13208 - Use real string for concatenation in note layer tooltip (patch by michael2402) + add unit test (regression from r8846) - gsoc-core

comment:5 Changed 3 years ago by aceman

But that string seems incorrect for proper translation. This is not how you produce a plural form. It should probably use trn().

comment:6 Changed 3 years ago by stoecker

In 10648/josm:

fix i18n, see #13208

comment:7 Changed 3 years ago by aceman

Thanks!

comment:8 Changed 3 years ago by Don-vip

In 10650/josm:

see #13208 - update unit test

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.