Modify

Opened 4 years ago

Closed 4 years ago

#13203 closed defect (fixed)

[Patch] Ctrl-D (Duplicate) places new object on top of source object

Reported by: hjart Owned by: team
Priority: major Milestone: 16.07
Component: Core Version: latest
Keywords: regression gsoc-core Cc: michael2402, mdk

Description

Rather than placing a duplicate under the cursor, Ctrl-D now places it on top of the source object.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-24 00:19:35 +0200 (Sun, 24 Jul 2016)
Build-Date:2016-07-24 01:39:57
Revision:10619
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10619 da) Linux openSUSE Leap 42.1 (x86_64)
Memory Usage: 915 MB / 1324 MB (291 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Java package: openjdk-8-jre:pakken openjdk-8-jre er ikke installeret

Plugins:
- DirectUpload (32329)
- FastDraw (32639)
- InfoMode (32491)
- Mapillary (32639)
- SimplifyArea (32517)
- apache-commons (32584)
- apache-http (32584)
- buildings_tools (32639)
- ejml (32639)
- geotools (32584)
- jts (32539)
- opendata (32584)
- reverter (32584)
- tagging-preset-tester (32584)
- todo (29154)
- utilsplugin2 (32584)
- wikipedia (32671)

Attachments (1)

patch-fix-13203.patch (3.0 KB) - added by michael2402 4 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 years ago by Don-vip

Ticket #13244 has been marked as a duplicate of this ticket.

comment:2 Changed 4 years ago by Don-vip

Cc: michael2402 added
Keywords: regression gsoc-core added
Milestone: 16.07

comment:3 Changed 4 years ago by Don-vip

Cc: mdk added

Changed 4 years ago by michael2402

Attachment: patch-fix-13203.patch added

comment:4 Changed 4 years ago by michael2402

Summary: Ctrl-D (Duplicate) places new object on top of source object[Patch] Ctrl-D (Duplicate) places new object on top of source object

I fixed that. The DuplicateAction is using the mouse position now.

comment:5 Changed 4 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10682/josm:

fix #13203 - Ctrl-D (Duplicate) places new object on top of source object (patch by michael2402) - gsoc-core

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.