Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13197 closed defect (fixed)

Autosave: EDT violation detected

Reported by: michael2402 Owned by: Don-vip
Priority: normal Milestone: 16.07
Component: Core Version: latest
Keywords: autosave edt java8 lambda regression Cc:

Description

org.openstreetmap.josm.gui.widgets.JMultilineLabel[,0,0,0x0,invalid,alignmentX=0.0,alignmentY=0.0,border=,flags=0,maximumSize=,minimumSize=,preferredSize=,caretColor=,disabledTextColor=,editable=true,margin=,selectedTextColor=,selectionColor=,kit=,typeHandlers=]
	at java.lang.Thread.getStackTrace(Thread.java:1552)
	at org.jdesktop.swinghelper.debug.CheckThreadViolationRepaintManager.checkThreadViolations(CheckThreadViolationRepaintManager.java:70)
	at org.jdesktop.swinghelper.debug.CheckThreadViolationRepaintManager.addDirtyRegion(CheckThreadViolationRepaintManager.java:61)
	at javax.swing.JComponent.repaint(JComponent.java:4793)
	at java.awt.Component.repaint(Component.java:3313)
	at javax.swing.text.JTextComponent.setEditable(JTextComponent.java:1758)
	at javax.swing.text.JTextComponent.<init>(JTextComponent.java:309)
	at javax.swing.JEditorPane.<init>(JEditorPane.java:199)
	at org.openstreetmap.josm.gui.widgets.JMultilineLabel.<init>(JMultilineLabel.java:47)
	at org.openstreetmap.josm.gui.widgets.JMultilineLabel.<init>(JMultilineLabel.java:35)
	at org.openstreetmap.josm.gui.Notification.setContent(Notification.java:104)
	at org.openstreetmap.josm.gui.Notification.<init>(Notification.java:78)
	at org.openstreetmap.josm.data.AutosaveTask.displayNotification(AutosaveTask.java:246)
	at org.openstreetmap.josm.data.AutosaveTask.run(AutosaveTask.java:234)
	at java.util.TimerThread.mainLoop(Timer.java:555)
	at java.util.TimerThread.run(Timer.java:505)
Build-Date:2016-07-24 10:20:25
Revision:10619
Is-Local-Build:true

Identification: JOSM/1.5 (10619 SVN de) Linux Ubuntu 14.04.3 LTS
Memory Usage: 224 MB / 224 MB (142 MB allocated, but free)
Java version: 1.8.0_66-b17, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dfile.encoding=UTF-8]
Dataset consistency test: No problems found

Plugins:
- graphview (32620)

Last errors/warnings:
- W: java.util.zip.ZipException: error in opening zip file
- W: PluginException:  org.openstreetmap.josm.plugins.PluginException: Ungültige JAR-Datei '<josm.pref>/plugins/ebdirigo.jar.new'
- W: Durchsuchen der Datei »ebdirigo.jar.new« nach Erweiterungsinformationen ist fehlgeschlagen. Datei wird übersprungen.
- W: Erweiterungen aktualisieren - org.openstreetmap.josm.plugins.PluginHandler$UpdatePluginsMessagePanel[,0,0,0x0,invalid,layout=java.awt.GridBagLayout,alignmentX=0.0,alignmentY=0.0,border=,flags=9,maximumSize=,minimumSize=,preferredSize=]
- W: Installation der Erweiterung <josm.pref>/plugins/ebdirigo.jar aus der temporären Datei '<josm.pref>/plugins/ebdirigo.jar.new' ist fehlgeschlagen. error in opening zip file java.util.zip.ZipException: error in opening zip file
- W: Cannot lock cache directory. Will not use disk cache

autosave.interval=1000
autosave.notification=true

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by Don-vip

Keywords: java8 lambda regression added
Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 3 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 10621/josm:

fix #13197 - bad use of method references instead of lambdas, causing graphical objects to be created in another thread than EDT

comment:3 Changed 3 years ago by michael2402

That's one of the reasons why I hate them ;-)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.