Modify

Opened 4 years ago

Closed 3 weeks ago

Last modified 3 weeks ago

#13177 closed defect (fixed)

Better handle errors while downloading parent ways/relations

Reported by: naoliv Owned by: team
Priority: critical Milestone: 20.05
Component: Core Version:
Keywords: download parent Cc:

Description

I have selected some nodes and clicked on Download parent ways/relations
Was waiting to finish and then when I saw, nothing happened.

Looking at console I can see:

(...)
INFO: GET https://api.openstreetmap.org/api/0.6/way/46609181/full -> 503 (387 B)
ERRO: org.openstreetmap.josm.io.OsmApiException: ResponseCode=503, Error Body=<<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>503 Service Unavailable</title>
</head><body>
<h1>Service Unavailable</h1>
<p>The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later.</p>
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at api.openstreetmap.org Port 443</address>
</body></html>>
org.openstreetmap.josm.io.OsmApiException: ResponseCode=503, Error Body=<<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>503 Service Unavailable</title>
</head><body>
<h1>Service Unavailable</h1>
<p>The server is temporarily unable to service your
request due to maintenance downtime or capacity
problems. Please try again later.</p>
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at api.openstreetmap.org Port 443</address>
</body></html>>
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:163)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStreamRaw(OsmServerReader.java:97)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:61)
	at org.openstreetmap.josm.io.OsmServerReader.getInputStream(OsmServerReader.java:44)
	at org.openstreetmap.josm.io.OsmServerObjectReader.parseOsm(OsmServerObjectReader.java:129)
	at org.openstreetmap.josm.io.OsmServerBackreferenceReader.readIncompletePrimitives(OsmServerBackreferenceReader.java:197)
	at org.openstreetmap.josm.io.OsmServerBackreferenceReader.parseOsm(OsmServerBackreferenceReader.java:247)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadReferrersTask.downloadParents(DownloadReferrersTask.java:146)
	at org.openstreetmap.josm.actions.downloadtasks.DownloadReferrersTask.realRun(DownloadReferrersTask.java:192)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:93)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:159)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
	at java.lang.Thread.run(Thread.java:745)

1A) Could JOSM give a message saying that there was a problem while downloading the data, without silently failing?
1B) Could JOSM offer to retry in this message?
2) Could JOSM, if possible, use/display the already downloaded data? In my case, it had downloaded a lot of data (but somehow it just ignored/discarded after the error, since it couldn't download the remaining data)

JOSM:

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-20 00:25:18 +0200 (Wed, 20 Jul 2016)
Build-Date:2016-07-20 01:32:00
Revision:10569
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10569 pt_BR) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 635 MB / 10206 MB (362 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-3-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]
Dataset consistency test: No problems found

Plugins:
- Create_grid_of_ways (32440)
- ImportImagePlugin (32584)
- OpeningHoursEditor (32583)
- PicLayer (32495)
- RoadSigns (32584)
- SimplifyArea (32517)
- apache-commons (32584)
- buildings_tools (32639)
- conflation (0.2.0)
- contourmerge (1014)
- download_along (32535)
- editgpx (32485)
- ejml (32639)
- geojson (42)
- geotools (32584)
- importvec (32490)
- indoorhelper (32637)
- jts (32539)
- log4j (32309)
- measurement (32454)
- merge-overlap (32471)
- opendata (32584)
- pbf (32584)
- pdfimport (32584)
- poly (32584)
- reverter (32584)
- scripting (30723)
- todo (29154)
- turnrestrictions (32629)
- undelete (32584)
- utilsplugin2 (32584)

Attachments (0)

Change History (4)

comment:1 Changed 4 months ago by GerdP

Ticket #16715 has been marked as a duplicate of this ticket.

comment:2 Changed 3 weeks ago by skyper

Keywords: download parent added
Priority: normalcritical
Type: enhancementdefect

Still reproducible:

In my eyes, this is a defect, especially when downloading parent relations, you do not get a notification if nothing (new) was found and downloaded or if there was a connection problem.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-05-10 15:58:34 +0200 (Sun, 10 May 2020)
Revision:16402
Build-Date:2020-05-11 01:30:50
URL:https://josm.openstreetmap.de/svn/trunk

comment:3 Changed 3 weeks ago by GerdP

Resolution: fixed
Status: newclosed

In 16405/josm:

fix #13177: Better handle errors while downloading parent ways/relations

  • show popup when an exception occurs

comment:4 Changed 3 weeks ago by GerdP

Milestone: 20.05

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.