Modify

Opened 5 years ago

Closed 5 years ago

#13119 closed defect (fixed)

Can't clear imagery cache from inside JOSM

Reported by: rickmastfan67 Owned by: wiktorn
Priority: major Milestone: 16.07
Component: Core imagery Version: latest
Keywords: regression jcs blockdiskcache Cc: Klumbumbus

Description

Steps to reproduce:

  1. Load an OSM file and activate any imagery source as a background.
  2. After you let the imagery source download the images, close both the data and imagery layer (but not JOSM).
  3. Preferences > Imagery Preferences > Cache contents
  4. Hit the clear button on which ever type of imagery you loaded. (Please note the # that's in the "Object Count" column before clearing that entry.)
  5. Notice it now says '0' in the "Object Count" column for that imagery source.
  6. Close & restart JOSM.
  7. Once JOSM has been restarted, Preferences > Imagery Preferences > Cache contents

What happens:
The imagery layer that you 'cleared' in Step 4 has the same # as before you 'cleared' it.

What should happen:
The imagery source shouldn't even be listed anymore since you supposedly cleared all it's files back in Step 4.

This "Clear" button had been working in the past, but it's now obviously no longer working. :( Only workaround for this is to manually go to the folder where the files are stored for the imagery downloads and manually delete all of the files. That's the only way currently to clear them out.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-07-08 03:20:06 +0200 (Fri, 08 Jul 2016)
Build-Date:2016-07-08 01:33:09
Revision:10521
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10521 en) Windows 7 64-Bit
Memory Usage: 574 MB / 1820 MB (377 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- OpeningHoursEditor (32309)
- buildings_tools (32309)
- measurement (32324)
- osmarender (32309)
- reverter (32309)
- turnlanes-tagging (1467927825)
- turnrestrictions (32386)
- undelete (32309)
- utilsplugin2 (32333)

Attachments (0)

Change History (8)

comment:1 Changed 5 years ago by wiktorn

Keywords: jcs blockdiskcache added

It looks like there is a bug in JCS BlockDiskCache that mishandles multiple object removal.

You can switch back do IndexedDiskCache by setting:

jcs.cache.use_block_cache=false

Until the bug will be fixed in JCS.

comment:2 Changed 5 years ago by anonymous

comment:3 Changed 5 years ago by Don-vip

Milestone: 16.07

comment:4 Changed 5 years ago by Don-vip

Owner: changed from team to wiktorn

comment:5 Changed 5 years ago by Don-vip

Cc: wiktorn removed

comment:6 Changed 5 years ago by Klumbumbus

Cc: Klumbumbus added

comment:7 Changed 5 years ago by Don-vip

comment:8 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain wiktorn.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.