Modify

Opened 4 years ago

Closed 4 years ago

#13109 closed defect (duplicate)

Cannot use multiple displays on Mac OS X

Reported by: Stereo Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report, macosx, firstworldproblems Cc:

Description

What steps will reproduce the problem?

  1. Connect a second display to your mac
  2. Open e.g. a relation editor, and move that window to the second screen
  3. Edit the map

What is the expected result?

Relation editor can stay on the second screen

What happens instead?

Window moves back to the first screen, becomes invisible

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 en_GB) Mac OS X 10.11.5
Memory Usage: 991 MB / 3641 MB (422 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Djava.library.path=/Applications/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DSandboxEnabled=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
- AddrInterpolation (32309)
- CommandLine (32329)
- DirectDownload (32309)
- DirectUpload (32329)
- FixAddresses (32309)
- HouseNumberTaggingTool (32309)
- ImportImagePlugin (32158)
- ImproveWay (1452443304)
- Mapillary (32158)
- OSMRecPlugin (32158)
- OpeningHoursEditor (32309)
- PicLayer (32329)
- RoadSigns (32309)
- ShapeTools (1000)
- alignways (32326)
- apache-commons (32309)
- apache-http (32309)
- areaselector (271)
- auto_tools (1466178229)
- buildings_tools (32309)
- cadastre-fr (32329)
- conflation (0.2.0)
- contourmerge (1014)
- download_along (32309)
- ejml (32309)
- geotools (32309)
- gson (32309)
- imagery-xml-bounds (32158)
- imagery_offset_db (32329)
- importvec (32158)
- josm-geojson (31245)
- jts (32311)
- livegps (32309)
- log4j (32309)
- mapdust (32329)
- merge-overlap (32309)
- namemanager (32309)
- opendata (32158)
- pdfimport (32309)
- pt_assistant (32540)
- public_transport (32309)
- public_transport_layer (32309)
- reverter (32309)
- scripting (30723)
- splinex (32309)
- surveyor (32329)
- tageditor (32309)
- terracer (32309)
- turnlanes (32309)
- turnrestrictions (32158)
- undelete (32309)
- utilsplugin2 (32158)

Tagging presets:
- http://osmtools.de/josm/steps.xml
- https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1

Map paint styles:
- http://maps.openstreetmap.ie/josm/townland.mapcss
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Suburb&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PowerMapping&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/TreeCrownDiameter&style&zip=1

Last errors/warnings:
- E: Failed to locate image ''

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by Stereo

Resolution: duplicate
Status: newclosed

Closed as duplicate of #12150.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.