Modify

Opened 3 years ago

Closed 3 years ago

#13091 closed defect (fixed)

java.lang.NoSuchMethodException: org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTester.<init>(org.openstreetmap.josm.plugins.PluginInformation)

Reported by: naoliv Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin tagging-preset-tester Version:
Keywords: Cc:

Description

While opening JOSM:

ERRO: org.openstreetmap.josm.plugins.PluginException: Um erro ocorreu com o plugin tagging-preset-tester. Causa: java.lang.NoSuchMethodException: org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTester.<init>(org.openstreetmap.josm.plugins.PluginInformation)
org.openstreetmap.josm.plugins.PluginException: Um erro ocorreu com o plugin tagging-preset-tester
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:329)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugin(PluginHandler.java:716)
	at org.openstreetmap.josm.plugins.PluginHandler.loadPlugins(PluginHandler.java:778)
	at org.openstreetmap.josm.plugins.PluginHandler.loadLatePlugins(PluginHandler.java:817)
	at org.openstreetmap.josm.gui.MainApplication.loadLatePlugins(MainApplication.java:551)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:481)
Caused by: java.lang.NoSuchMethodException: org.openstreetmap.josm.plugins.taggingpresettester.TaggingPresetTester.<init>(org.openstreetmap.josm.plugins.PluginInformation)
	at java.lang.Class.getConstructor0(Class.java:3082)
	at java.lang.Class.getConstructor(Class.java:1825)
	at org.openstreetmap.josm.plugins.PluginInformation.load(PluginInformation.java:325)
	... 5 more

JOSM:

Build-Date:2016-06-30 21:38:37
Revision:10504
Is-Local-Build:true

Identification: JOSM/1.5 (10504 SVN pt_BR) Linux Debian GNU/Linux unstable (sid)
Memory Usage: 247 MB / 4029 MB (129 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-3-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
VM arguments: [-Dawt.useSystemAAFontSettings=on]

Plugins:
- AddrInterpolation (32309)
- Create_grid_of_ways (32309)
- FastDraw (32309)
- FixAddresses (32309)
- ImportImagePlugin (32326)
- OpeningHoursEditor (32309)
- PicLayer (32329)
- SimplifyArea (32309)
- apache-commons (32309)
- buildings_tools (32309)
- download_along (32309)
- editgpx (32309)
- ejml (32309)
- geotools (32309)
- graphview (32344)
- jogl (1.0.46)
- jts (32311)
- kendzi3d (1.0.190.1)
- kendzi3d-resources (0.0.1)
- log4j (32309)
- measurement (32324)
- merge-overlap (32309)
- opendata (32351)
- pdfimport (32309)
- photo_geotagging (32326)
- poly (32309)
- reverter (32309)
- tagging-preset-tester
- todo (29154)
- turnlanes-tagging (1466175713)
- turnrestrictions (32386)
- undelete (32309)
- utilsplugin2 (32333)

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by Don-vip

Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 3 years ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o32526:32527]. regression from [o32306], trigerred by [o32504].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.