Modify

Opened 5 years ago

Closed 5 years ago

#13009 closed defect (fixed)

NPE on startup of JOSM

Reported by: rickmastfan67 Owned by: team
Priority: major Milestone: 16.06
Component: Core Version: latest
Keywords: template_report regression gsoc-core Cc: michael2402, Klumbumbus

Description

Just saw this in the command line of Java. Didn't show the bug reporting screen. Thankfully I was able to copy/paste the info from the console.

ERROR: java.lang.reflect.InvocationTargetException. Cause: java.lang.NullPointerException
java.lang.reflect.InvocationTargetException
        at java.awt.EventQueue.invokeAndWait(Unknown Source)
        at java.awt.EventQueue.invokeAndWait(Unknown Source)
        at javax.swing.SwingUtilities.invokeAndWait(Unknown Source)
        at org.openstreetmap.josm.gui.util.GuiHelper.runInEDTAndWait(GuiHelper.java:127)
        at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:321)
Caused by: java.lang.NullPointerException
        at org.openstreetmap.josm.data.Preferences.getUserDataDirectory(Preferences.java:295)
        at org.openstreetmap.josm.tools.ImageProvider.getImageUrl(ImageProvider.java:1188)
        at org.openstreetmap.josm.tools.ImageProvider.getIfAvailableImpl(ImageProvider.java:915)
        at org.openstreetmap.josm.tools.ImageProvider.getResource(ImageProvider.java:640)
        at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:622)
        at org.openstreetmap.josm.tools.ImageProvider.get(ImageProvider.java:789)
        at org.openstreetmap.josm.gui.widgets.TextContextualPopupMenu.addMenuEntry(TextContextualPopupMenu.java:182)
        at org.openstreetmap.josm.gui.widgets.TextContextualPopupMenu.addMenuEntries(TextContextualPopupMenu.java:115)
        at org.openstreetmap.josm.gui.widgets.TextContextualPopupMenu.attach(TextContextualPopupMenu.java:100)
        at org.openstreetmap.josm.gui.widgets.TextContextualPopupMenu.enableMenuFor(TextContextualPopupMenu.java:150)
        at org.openstreetmap.josm.gui.widgets.JosmEditorPane.<init>(JosmEditorPane.java:33)
        at org.openstreetmap.josm.gui.GettingStarted$LinkGeneral.<init>(GettingStarted.java:54)
        at org.openstreetmap.josm.gui.GettingStarted.<init>(GettingStarted.java:123)
        at org.openstreetmap.josm.gui.MainPanel.getGettingStarted(MainPanel.java:149)
        at org.openstreetmap.josm.gui.MainPanel.updateContent(MainPanel.java:71)
        at org.openstreetmap.josm.gui.MainApplication$1.run(MainApplication.java:324)
        at java.awt.event.InvocationEvent.dispatch(Unknown Source)
        at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
        at java.awt.EventQueue.access$500(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.awt.EventQueue$3.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
        at java.awt.EventQueue.dispatchEvent(Unknown Source)
        at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
        at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
        at java.awt.EventDispatchThread.run(Unknown Source)

Doesn't seem to completely break JOSM, but does seem to prevent the opening screen that shows the recent major changes on from loading, as I was able to open a saved file.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-20 02:47:43 +0200 (Mon, 20 Jun 2016)
Build-Date:2016-06-20 01:34:14
Revision:10436
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10436 en) Windows 7 64-Bit
Memory Usage: 695 MB / 1820 MB (394 MB allocated, but free)
Java version: 1.8.0_77-b03, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- OpeningHoursEditor (32158)
- buildings_tools (32158)
- measurement (32324)
- osmarender (31772)
- reverter (32158)
- turnlanes-tagging (1466175713)
- turnrestrictions (32158)
- undelete (32158)
- utilsplugin2 (32158)

Attachments (1)

patch-fix-13009.patch (2.2 KB) - added by michael2402 5 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 5 years ago by Don-vip

Cc: michael2402 added
Keywords: template_report regression gsoc-core added
Priority: criticalmajor

comment:2 Changed 5 years ago by Don-vip

Milestone: 16.06

Changed 5 years ago by michael2402

Attachment: patch-fix-13009.patch added

comment:3 Changed 5 years ago by michael2402

I attached a patch that moves the construction of the GettingStarted panel later in main. This should solve that dependency problem.

In the long run I want to solve this by getting rid of Main.panel (which has only few uses in plugins - most of which are repaint() calls).

comment:4 Changed 5 years ago by Klumbumbus

Cc: Klumbumbus added

comment:5 Changed 5 years ago by Klumbumbus

Ticket #13014 has been marked as a duplicate of this ticket.

comment:6 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10442/josm:

fix #13009 - NPE on startup of JOSM (patch by michael2402) - gsoc-core

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.