Modify

Opened 3 years ago

Last modified 6 months ago

#13007 reopened defect

Enlarge small monospaced font used throughout interface

Reported by: RicoElectrico Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report hidpi Cc: stoecker, strump

Description (last modified by Don-vip)

At least on Windows, there are several instances (like Note comment box or configuration report) where awkwardly small Courier-like font is used. It's almost unreadable on high DPI screens - on normal screens it isn't good either.



URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-05-02 10:23:17 +0200 (Mon, 02 May 2016)
Build-Date:2016-05-03 01:31:45
Revision:10168
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10168 pl) Windows 8.1 64-Bit
Memory Usage: 426 MB / 910 MB (109 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- BuildingGeneralization (UNKNOWN)
- FastDraw (32158)
- FixAddresses (32158)
- HouseNumberTaggingTool (31926)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- ShowInGoogleMaps (8)
- SimplifyArea (32158)
- Tracer2 (32158)
- alignways (32161)
- apache-commons (32158)
- buildings_tools (32158)
- contourmerge (1014)
- dataimport (31926)
- editgpx (32158)
- ejml (32158)
- geotools (31895)
- gson (32158)
- imagery_offset_db (32158)
- importvec (32158)
- jogl (1.0.46)
- josm-plugin-opengl (1440156917)
- jts (31906)
- kendzi3d (1.0.190.1)
- kendzi3d-resources (0.0.1)
- log4j (32158)
- mapdust (31923)
- measurement (32158)
- opendata (32158)
- pbf (32158)
- photo_geotagging (32158)
- poly (32158)
- reverter (32158)
- splinex (32158)
- surveyor2 (29210)
- terracer (32158)
- todo (29154)
- undelete (32158)
- utilsplugin2 (32158)
- wikipedia (32182)

Tagging presets:
- http://somewhere.dk/email/josm/source.xml

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://github.com/gmgeo/osmic-josm-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1

Validator rules:
- %UserProfile%\Desktop\skroty.validator.mapcss

Attachments (2)

josm1.png (7.5 KB) - added by RicoElectrico 3 years ago.
josm2.png (25.1 KB) - added by RicoElectrico 3 years ago.

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by RicoElectrico

Attachment: josm1.png added

Changed 3 years ago by RicoElectrico

Attachment: josm2.png added

comment:1 Changed 3 years ago by Don-vip

Cc: stoecker strump added
Keywords: hidpi added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #9995.
We're currently working on hidpi support, see #9995. Can you please try with josm latest and report feedback there?

comment:2 Changed 3 years ago by bastiK

Resolution: duplicate
Status: closedreopened

@Don-vip:
This looks like a bug on a screen with standard resolution. (Just that on a hidpi screen the problem is amplified.)

@RicoElectrico:
Could you please compare this to the font-size of a text area that uses normal (proportional) font? (For example Help > About > Readme Tab.) It should be the same.

comment:3 Changed 3 years ago by RicoElectrico

@bastiK
The area you mention also uses non-proportional font. In fact, I couldn't find any text area with proportional font.

comment:4 Changed 3 years ago by bastiK

Thanks!

Related discussion and possible fix.

comment:5 Changed 6 months ago by Don-vip

Description: modified (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as reopened The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to RicoElectrico
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.