Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12992 closed defect (fixed)

Way with waterway=dam cause false validator warning

Reported by: mdk Owned by: team
Priority: normal Milestone: 16.06
Component: Core validator Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open validateDam.osm
  2. validate

What is the expected result?

No warnings, because a dam as a simple way normally is a little bit wider then the water behind the dam. So the end nodes of the dam are normally not connected to other waterway=*

What happens instead?

Warning "Waterway ends without a connection to other waterway or the direction of the waterway is wrong."

Please provide any additional information below. Attach a screenshot if possible.

If you copy all and past it to a new layer, validation shown no warning.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-17 02:58:36 +0200 (Fri, 17 Jun 2016)
Build-Date:2016-06-17 01:34:23
Revision:10409
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10409 en) Linux Ubuntu 15.10
Memory Usage: 427 MB / 876 MB (165 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-0ubuntu4~15.10.1-b14, Oracle Corporation, OpenJDK Server VM
VM arguments: [-Djosm.restart=true, -Djosm.home=<josm.pref>, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
- ColumbusCSV (32292)
- FastDraw (32158)
- HouseNumberTaggingTool (31926)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- RoadSigns (32177)
- SimplifyArea (32158)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- contourmerge (1014)
- imagery-xml-bounds (32287)
- imagery_offset_db (32158)
- pbf (32290)
- poly (32287)
- public_transport (32158)
- reltoolbox (32158)
- reverter (32158)
- terracer (32158)
- turnlanes (32158)
- turnrestrictions (32158)
- utilsplugin2 (32158)

Tagging presets:
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Traffic_signs&zip=1

Last errors/warnings:
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryMainDialog$StopAction@ded068
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryHistoryDialog$UndoAction@13eca2c
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryHistoryDialog$RedoAction@e45ab2
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryFilterDialog$UpdateAction@75c1fc
- W: Old style SideButton usage for action org.openstreetmap.josm.plugins.mapillary.gui.MapillaryFilterDialog$ResetAction@11c1769

Attachments (1)

validateDam.osm (6.3 KB) - added by mdk 3 years ago.

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by mdk

Attachment: validateDam.osm added

comment:1 Changed 3 years ago by Don-vip

Milestone: 16.06

comment:2 Changed 3 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10422/josm:

fix #12992 - Way with waterway=dam cause false validator warning

comment:3 Changed 3 years ago by mdk

Wow, that was fast!!

For the second part

If you copy all and past it to a new layer, validation shown no warning.

I think I found the reason, but I will create a new ticket instead of post it here ;-)

comment:4 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: closedreopened

I think it is even better to explicit use the wanted waterway tags instead of applying this rule to all waterways with some exception because there are so much different values, we could never exlude them all to avoid false positives. http://taginfo.openstreetmap.org/keys/waterway#values

comment:5 Changed 3 years ago by mdk

For the second part see #12993

comment:6 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

In 10427/josm:

see #12646, fix #12992 - limit "Unconnected waterway or wrong way flow" warning to waterway=stream|ditch|river|drain

comment:7 Changed 3 years ago by Klumbumbus

Ticket #13026 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.