Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#12976 closed defect (fixed)

MapView is not refreshed when the active layer is hidden/shown

Reported by: Don-vip Owned by: team
Priority: major Milestone: 16.06
Component: Core Version:
Keywords: template_report gsoc-core regression Cc: wiktorn, michael2402, bastiK

Description

What steps will reproduce the problem?

  1. Download OSM data
  2. Hide the active layer using eye icon in layer list dialog
  3. Notice the map view is not refreshed
  4. Move the mouse over map view
  5. Notice the map view is refreshed only once the mouse enters the map view area

What is the expected result?

  1. Map view should be refreshed as soon the layer visibility changes. Regression from r10391 (r10390 works fine)
Build-Date:2016-06-16 15:23:08
Revision:10391
Is-Local-Build:true

Identification: JOSM/1.5 (10391 SVN en) Windows 10 64-Bit
Memory Usage: 402 MB / 3634 MB (214 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dfile.encoding=UTF-8]
Program arguments: [--debug]

Plugins:
- cadastre-fr (32212)
- continuosDownload (53)
- editgpx (32263)
- ejml (32158)
- geotools (31895)
- jts (31906)
- log4j (32158)
- measurement (32158)
- utilsplugin2 (32158)

Last errors/warnings:
- W: Missing plugin main version in plugin OSMRecPlugin

Attachments (1)

patch-fix-12976.patch (1.3 KB) - added by michael2402 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by michael2402

Attachment: patch-fix-12976.patch added

comment:1 Changed 5 years ago by michael2402

Thanks for the report. I added a patch to fix it.

Was caused by [10391]

comment:2 Changed 5 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10401/josm:

fix #12976 - MapView is not refreshed when the active layer is hidden/shown (patch by michael2402) - gsoc-core

comment:3 Changed 5 years ago by Don-vip

thanks! I think it was the last regression :)

comment:4 Changed 5 years ago by michael2402

Well, there are still the test cases failing. And I would not be surprised if we find some more failing removeListener()/destroy() calls.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.