Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12966 closed defect (fixed)

continuosDownload doesn't work anymore

Reported by: danidoedel Owned by: danidoedel
Priority: critical Milestone:
Component: Plugin continuosDownload Version: latest
Keywords: continuosDownload template_report Cc: strump, stoecker

Description (last modified by stoecker)

What steps will reproduce the problem?

  1. Start JOSM
  2. Error message will be displayed if continuosDownload should be disabled

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-12 23:40:12 +0200 (Sun, 12 Jun 2016)
Build-Date:2016-06-13 01:33:32
Revision:10367
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10367 de) Windows 10 64-Bit
Memory Usage: 441 MB / 910 MB (307 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
VM arguments: [-Dsun.java2d.opengl=false]

Plugins:
- FixAddresses (32158)
- HouseNumberTaggingTool (31926)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- apache-commons (32158)
- apache-http (32158)
- continuosDownload
- geochat (32158)
- graphview (32158)
- gson (32158)
- jts (31906)
- log4j (32158)
- mapdust (31923)
- public_transport_layer (32158)
- reverter (32158)
- routing (32158)
- turnlanes (32158)
- turnrestrictions (32158)

Tagging presets:
- http://www.country-linedance.de/daten/Verkehrszeichen-vorlage.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/TMC&zip=1

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1

Last errors/warnings:
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: org.openstreetmap.josm.plugins.PluginException: In der Erweiterung continuosDownload ist ein Fehler aufgetreten.. Ursache: java.lang.reflect.InvocationTargetException. Ursache: java.lang.RuntimeException: Fehler: Das Bild 'images/continuous-download.???' konnte nicht geladen werden. Das ist ein schwerwiegendes Konfigurationsproblem.
- W: Erweiterung deaktivieren - Erweiterung continuosDownload konnte nicht geladen werden. Aus den Einstellungen entfernen?

Not sure if helpful or not:
https://i.imgur.com/Y5gybbM.png

Attachments (0)

Change History (20)

comment:1 Changed 4 years ago by Don-vip

Owner: changed from team to danidoedel
Status: newneedinfo

This error has already been fixed, can you please try to update your plugins?

comment:2 Changed 4 years ago by danidoedel

Already tried to update and reinstall the plugin. JOSM says all my plugins are up to date (Version 44 (local: 44))... Is https://josm.openstreetmap.de/pluginicons%<?plugins=> the correct plugin site?

comment:3 Changed 4 years ago by Don-vip

Yes it is correct. I Have issued a new version of the plugin (51), can you please try again?

comment:4 Changed 4 years ago by danidoedel

Still doesn't work. Tried it on another system too with same results. Works fine with the stable version of JOSM.

comment:5 Changed 4 years ago by Don-vip

can you please attach a new status report?

comment:6 Changed 4 years ago by danidoedel

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-14 22:25:40 +0200 (Tue, 14 Jun 2016)
Build-Date:2016-06-15 01:34:12
Revision:10377
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10377 en) Windows 10 64-Bit
Memory Usage: 565 MB / 1796 MB (416 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM

Plugins:
- FixAddresses (32158)
- HouseNumberTaggingTool (31926)
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- apache-commons (32158)
- apache-http (32158)
- continuosDownload
- geochat (32158)
- graphview (32158)
- gson (32158)
- jts (31906)
- log4j (32158)
- mapdust (31923)
- public_transport_layer (32158)
- reverter (32158)
- routing (32158)
- turnlanes (32158)
- turnrestrictions (32158)

Tagging presets:
- http://www.country-linedance.de/daten/Verkehrszeichen-vorlage.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/TMC&zip=1

Map paint styles:
- https://github.com/bastik/mapcss-tools/raw/osm/mapnik2mapcss/osm-results/mapnik.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1

Last errors/warnings:
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: No tagging preset submenu for   
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin continuosDownload. Cause: java.lang.reflect.InvocationTargetException. Cause: java.lang.RuntimeException: Fatal: failed to locate image 'images/continuous-download.???'. This is a serious configuration problem. JOSM will stop working.
- W: Disable plugin - Could not load plugin continuosDownload. Delete from preferences?

comment:7 Changed 4 years ago by Don-vip

This should not happen, can you please try to delete %APPDATA%\JOSM\plugins\continuosDownload.jar and download it again?

comment:8 Changed 4 years ago by danidoedel

I deleted both JOSM folders in %APPDATA%\Local and %APPDATA%\Roaming, downloaded the plugin again and the same issue appeared. That's weird...

comment:9 Changed 4 years ago by Don-vip

Ah, sorry, I forgot to mention the new plugin requires JOSM >= 10282 so you must run JOSM latest to use it.

comment:10 Changed 4 years ago by anonymous

I always run JOSM latest, currently 10377.

JOSM latest (10377): plugin doesn't work
JOSM tested (10327): plugin does work

But both are JOSM > 10282...

comment:11 Changed 4 years ago by Don-vip

Cc: strump stoecker added

@team: could it be caused by latest changes from #9995?

comment:12 Changed 4 years ago by Don-vip

Resolution: fixed
Status: needinfoclosed

ok change of behaviour of r10358. I have released a new version of the plugin:
https://github.com/JOSM/JOSM-continuos-download/releases/tag/v1.2.4

it should be listed in https://josm.openstreetmap.de/plugin in the next 10 minutes.

Last edited 4 years ago by Don-vip (previous) (diff)

comment:13 Changed 4 years ago by danidoedel

Thank you! It's working again ;)

comment:14 Changed 4 years ago by stoecker

Can you explain the reason. There should be no effect on the image path handling.

comment:15 Changed 4 years ago by Don-vip

I don't fully understand, but ImageProvider gets to look for "images/" + the given path, so "images/images/foo.png" is not resolved.

comment:16 Changed 4 years ago by stoecker

It's this change: 10358/josm/trunk/src/org/openstreetmap/josm/plugins/PluginInformation.java.

Works:
svn up -r 10358 && svn up -r 10357 src/org/openstreetmap/josm/plugins/PluginInformation.java
Fails:
svn up -r 10358

But actually this has nothing to do with the current issue. Maybe some caching problem? Probably before the JOSM action used the illegally cached variant of "images/continuous-download", because it's loaded in PluginLoader. Now it's delayed and thus the JosmAction loads, which does not allow an "images/" before for internal resources.

Seems the caching should be fixed?

comment:17 Changed 4 years ago by stoecker

Description: modified (diff)

comment:18 Changed 4 years ago by Don-vip

If you want to debug the issue, the plugins BuildingGeneralization and rex are still impacted.

comment:19 Changed 4 years ago by stoecker

With above svn command it's easy to debug. Question is if I want to do it. :-)

Anyway the plugins need to be fixed, the code is wrong even if it worked before.

comment:20 Changed 4 years ago by stoecker

In 10403/josm:

see #12966 - don't mix caching of resource and zip-archive images

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain danidoedel.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.