Modify

Opened 4 years ago

Closed 3 years ago

#12939 closed defect (duplicate)

Overpass geocodeArea support and area query

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: overpass Cc: simon04, bastiK, tyr_asd

Description

It is possible to query in Overpass API using place names?

When I create query using "power=cable in Berlin" in overpass creator I receive:

[out:xml][timeout:25];
{{geocodeArea:Berlin}}->.searchArea;
(
  node["power"="cable"](area.searchArea);
  way["power"="cable"](area.searchArea);
  relation["power"="cable"](area.searchArea);
);
(._;>;);
out meta;

But executing it give me http error 400.

When I replace manually {{geocodeArea:Berlin}} by area(3600062422) then I receive data in this place but also in selected bbox - power=cable in Berlin in bbox

I found some informations about that:
http://wiki.openstreetmap.org/wiki/Overpass_turbo/Extended_Overpass_Turbo_Queries#Available_Shortcuts

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-06 23:43:32 +0200 (Mon, 06 Jun 2016)
Build-Date:2016-06-07 01:32:04
Revision:10331
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10331 pl) Linux Ubuntu 16.04 LTS
Memory Usage: 241 MB / 869 MB (54 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-0ubuntu4~16.04.1-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- Mapillary (32158)
- OpeningHoursEditor (32158)
- PicLayer (32158)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- ejml (32158)
- geotools (31895)
- jts (31906)
- measurement (32158)
- opendata (32158)
- reverter (32158)
- tag2link (31923)
- tageditor (32158)
- utilsplugin2 (32158)

Tagging presets:
- https://raw.githubusercontent.com/jacobbraeutigam/JOSM_Preset_street_cabinet/master/street_cabinet.xml
- https://raw.githubusercontent.com/zibik/stork_nests/master/stork_preset.xml

Map paint styles:
- /data${HOME}2/Pulpit/pulpit2/power.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&zip=1

Last errors/warnings:
- E: Błędne żądanie - <html>Serwer OSM 'overpass-api.de' zgłosił błędne żądanie.<br></html>

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by Don-vip

Cc: simon04 bastiK tyr_asd added

comment:2 Changed 3 years ago by Don-vip

Milestone: 16.06

comment:3 Changed 3 years ago by Don-vip

Milestone: 16.0616.07

comment:4 Changed 3 years ago by simon04

Milestone: 16.07
Resolution: duplicate
Status: newclosed

Closed as duplicate of #11975.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.