Modify

Opened 4 years ago

Closed 4 years ago

#12923 closed defect (duplicate)

Joining new polygon with old polygon creates polygon with new id

Reported by: hjart Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description (last modified by hjart)

What steps will reproduce the problem?

  1. Download a polygon (e.g. a building)
  2. Create an overlapping polygon.
  3. Join the two polygons (shift-j).

What is the expected result?

A modified version of the downloaded polygon (with original osm-id) ready to upload is produced. The history of the original polygon should be kept.

What happens instead?

A modified version of the downloaded polygon, but with no osm-id, which means it gets a new one when uploaded and that history for the polygon is lost. Note that the id's of undeleted original nodes are kept.

Please provide any additional information below. Attach a screenshot if possible.

The particular polygon where I first noticed this behaviour is https://www.openstreetmap.org/way/423110898. It's easier to see what's going on in http://overpass-api.de/achavi/?changeset=39835306. Look for "Ørum Varmeværk".

Instead of a red and green polygon there should have been a blue, indicating that the building was only modified
The above image produced by the diffmap at https://osm.expandable.dk/ was how I discovered it. The modified building should have been represented by a blue polygon rather than a red and green.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-06-04 17:28:58 +0200 (Sat, 04 Jun 2016)
Build-Date:2016-06-04 15:31:27
Revision:10327
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10327 da) Linux openSUSE Leap 42.1 (x86_64)
Memory Usage: 705 MB / 1324 MB (167 MB allocated, but free)
Java version: 1.8.0_91-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Dataset consistency test: No problems found

Plugins:
- DirectUpload (32158)
- FastDraw (32158)
- InfoMode (32158)
- Mapillary (32158)
- SimplifyArea (32158)
- apache-commons (32158)
- apache-http (32158)
- buildings_tools (32158)
- reverter (32158)
- tagging-preset-tester (32158)
- todo (29154)
- utilsplugin2 (32158)
- wikipedia (32182)

Tagging presets:
- ${HOME}/Dokumenter/HjartsPresets.xml
- http://www.country-linedance.de/daten/Archaeologie-de.zip
- https://josm.openstreetmap.de/josmfile?page=Presets/OneClick&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Quick-highways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Presets/Quick-stops&zip=1

Attachments (1)

ØrumVarmeværk.png (12.2 KB) - added by hjart 4 years ago.
Instead of a red and green polygon there should have been a blue, indicating that the building was only modified

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by hjart

Attachment: ØrumVarmeværk.png added

Instead of a red and green polygon there should have been a blue, indicating that the building was only modified

comment:1 Changed 4 years ago by hjart

Description: modified (diff)

comment:2 Changed 4 years ago by hjart

Description: modified (diff)

comment:3 Changed 4 years ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #9599.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.