Modify

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#12899 closed enhancement (fixed)

Surfaces

Reported by: Szem Owned by: team
Priority: normal Milestone: 16.06
Component: Internal preset Version:
Keywords: surface, order Cc:

Description

What steps will reproduce the problem?

  1. Change object dialog box
  2. Surface drop-down menu

What is the expected result?

Hi,

I,ve got two problems:

  1. I think that was better when more surfaces were in the drop-down menu. Some often used is missing, and some rare used used is in it. (the most mising tags: concrete:plates, fine_gravel)

Both of them is in the first page of the surfaces tags:
https://taginfo.openstreetmap.org/keys/surface#values

  1. But it would be even more better, to change the alphabetic order to tematic order. I've made one:

paved - general
unpaved
---
asphalt - solid surfaces
concrete
concrete:plates
concrete:lanes
paving_stones
sett
cobblestone
grass_paver
---
compacted - not solid / natural surfaces
fine_gravel
gravel
pebblestone
ground
clay
mud
sand
grass
---
wood - special surfaces
metal
tartan
artificial_turf

Thanks for your answer!

Szem

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-05-30 02:06:54 +0200 (Mon, 30 May 2016)
Build-Date:2016-05-30 01:32:45
Revision:10301
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10301 hu) Windows 7 64-Bit
Memory Usage: 754 MB / 989 MB (358 MB allocated, but free)
Java version: 1.8.0_71-b15, Oracle Corporation, Java HotSpot(TM) Client VM
Dataset consistency test: No problems found

Plugins:
- turnrestrictions (32158)

Tagging presets:
- URL: http://openmaps.eu/presets/TUHU-presets.zip

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by Klumbumbus

Component: CoreInternal preset
Milestone: 16.06

comment:2 Changed 3 years ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 10319/josm:

fix #12899 - update surface values

comment:3 Changed 3 years ago by Klumbumbus

clay, tartan and artificial_turf are in the more special surface combo box of leisure=pitch and leisure=track.

I kept the alphapetical order for consistency because all other combo boxes are also in alphabetical order. I think it is easier to find the correct value when they are sorted alphabetical.

You can set taggingpreset.sortvalues to false in the advanced preferences. However this will change the order of all(!) presets to the order written in the preset file http://josm.openstreetmap.de/browser/josm/trunk/data/defaultpresets.xml

comment:4 Changed 3 years ago by Klumbumbus

-- comment deleted -- (was typo in ticket number)

Last edited 3 years ago by Klumbumbus (previous) (diff)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.