Modify

Opened 8 years ago

Closed 7 years ago

#12873 closed enhancement (duplicate)

Should close the changeset when splitting it at the 50k limit

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: Cc:

Description

Already saw this happening 2 times with friends: while uploading a very large changeset, with more than 50000 objects, JOSM splits the changeset (as it should, due to the 50000 maximum elements limit).
But there is one issue: JOSM closes only the last changeset, leaving the first ones to be closed automatically by the API timeout.

For example, one changeset started here https://www.openstreetmap.org/api/0.6/changeset/39411216 at 21:16 hours then JOSM started a new one here https://www.openstreetmap.org/api/0.6/changeset/39412061 at 22:00.
Note that the second changeset was then closed at 22:27 while the first one was closed at 23:00 (since it hit the 1 hour API timeout).

Before creating a new changeset in cases where a split is necessary, JOSM should first close the older one and only then continue the needed actions.

Attachments (0)

Change History (1)

comment:1 by Don-vip, 7 years ago

Resolution: duplicate
Status: newclosed

Closed as duplicate of #11077.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences .
 
Note: See TracTickets for help on using tickets.