Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12847 closed defect (fixed)

ExceptionInInitializerError in ElemStyles.generateStyles - NPE in NodeElement.createIcon

Reported by: anonymous Owned by: team
Priority: blocker Milestone: 16.05
Component: Core Version:
Keywords: template_report regression Cc:

Description

What steps will reproduce the problem?

  1. Start build 8132

What is the expected result?

What happens instead?

Unexpected Exception

Please provide any additional information below. Attach a screenshot if possible.

URL:http://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2016-05-17 02:32:56 +0200 (Tue, 17 May 2016)
Build-Date:2016-05-17 01:32:14
Revision:10238
Relative:URL: ^/trunk

Identification: JOSM/1.5 (10238 en) Linux Debian GNU/Linux testing (stretch)
Memory Usage: 274 MB / 683 MB (178 MB allocated, but free)
Java version: 1.8.0_91-8u91-b14-2-b14, Oracle Corporation, OpenJDK 64-Bit Server VM
Program arguments: [--offline=all]
Dataset consistency test: No problems found

Plugins:
- geotools (31000)
- jts (31002)
- log4j (30892)
- print (30892)
- proj4j (30892)

Last errors/warnings:
- W: JOSM is running in offline mode. This resource will not be available: ALL
- W: Unable to access 'https://josm.openstreetmap.de/maps': JOSM website not available (offline mode)
- E: org.openstreetmap.josm.plugins.PluginException: An error occurred in plugin measurement. Cause: java.lang.NoClassDefFoundError: org/openstreetmap/josm/gui/NavigatableComponent$SoMChangeListener. Cause: java.lang.ClassNotFoundException: org.openstreetmap.josm.gui.NavigatableComponent$SoMChangeListener
- W: Disable plugin - Could not load plugin measurement. Delete from preferences?
- E: java.lang.ExceptionInInitializerError. Cause: java.lang.NullPointerException

java.lang.ExceptionInInitializerError
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.generateStyles(ElemStyles.java:360)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getImpl(ElemStyles.java:190)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.getStyleCacheWithRange(ElemStyles.java:104)
	at org.openstreetmap.josm.gui.mappaint.ElemStyles.get(ElemStyles.java:83)
	at org.openstreetmap.josm.gui.NavigatableComponent$1.evaluate(NavigatableComponent.java:89)
	at org.openstreetmap.josm.gui.NavigatableComponent$1.evaluate(NavigatableComponent.java:82)
	at org.openstreetmap.josm.gui.NavigatableComponent.getNearestNodesImpl(NavigatableComponent.java:804)
	at org.openstreetmap.josm.gui.NavigatableComponent.getNearestNode(NavigatableComponent.java:935)
	at org.openstreetmap.josm.gui.NavigatableComponent.getNearestNodeOrWay(NavigatableComponent.java:1373)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.giveUserFeedback(SelectAction.java:247)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.giveUserFeedback(SelectAction.java:236)
	at org.openstreetmap.josm.actions.mapmode.SelectAction.mouseMoved(SelectAction.java:478)
	at java.awt.AWTEventMulticaster.mouseMoved(AWTEventMulticaster.java:330)
	at java.awt.AWTEventMulticaster.mouseMoved(AWTEventMulticaster.java:329)
	at java.awt.Component.processMouseMotionEvent(Component.java:6580)
	at javax.swing.JComponent.processMouseMotionEvent(JComponent.java:3342)
	at java.awt.Component.processEvent(Component.java:6304)
	at java.awt.Container.processEvent(Container.java:2236)
	at java.awt.Component.dispatchEventImpl(Component.java:4891)
	at java.awt.Container.dispatchEventImpl(Container.java:2294)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4888)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4538)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4466)
	at java.awt.Container.dispatchEventImpl(Container.java:2280)
	at java.awt.Window.dispatchEventImpl(Window.java:2750)
	at java.awt.Component.dispatchEvent(Component.java:4713)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:86)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.awt.EventQueue$4.run(EventQueue.java:729)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
	at org.GNOME.Accessibility.AtkWrapper$5.dispatchEvent(AtkWrapper.java:697)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.gui.mappaint.styleelement.NodeElement.createIcon(NodeElement.java:148)
	at org.openstreetmap.josm.gui.mappaint.styleelement.NodeElement.create(NodeElement.java:111)
	at org.openstreetmap.josm.gui.mappaint.styleelement.NodeElement.<clinit>(NodeElement.java:86)
	... 46 more

Attachments (0)

Change History (7)

comment:1 Changed 6 years ago by Don-vip

Ticket #12848 has been marked as a duplicate of this ticket.

comment:2 Changed 6 years ago by Don-vip

Ticket #12849 has been marked as a duplicate of this ticket.

comment:3 Changed 6 years ago by Don-vip

Ticket #12850 has been marked as a duplicate of this ticket.

comment:4 Changed 6 years ago by Don-vip

Keywords: regression added
Milestone: 16.05
Priority: normalblocker
Summary: Repeated "Unexpected Exception" in build 8132ExceptionInInitializerError in ElemStyles.generateStyles - NPE in NodeElement.createIcon

comment:5 Changed 6 years ago by Don-vip

Ticket #12846 has been marked as a duplicate of this ticket.

comment:6 Changed 6 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 10240/josm:

fix #12847 - NPE - regression of r10238

comment:7 Changed 6 years ago by Don-vip

Ticket #12852 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.